3

I have a home server that I want to make multicast a music stream to my network. I have the server connected to my main network router via WiFi, and I have a switch connected to the server by wire where I've plugged in some clients. These clients are to be able to play the music stream from the multicast source.

When I configure the network in this respect, I find the wireless network crumbles. I think this is because the router gets loaded, because the same thing happens when I connect the server playing the multicast stream to the router by wire.

So, instead of crowding my main network, I would like to create a separate, wired network with the server that keeps the multicasting separate from the main wireless network. However, the added complication is that the server needs an internet connection to be able to receive the music stream which it will then multicast.

I've managed to configure a DHCP server on the home server, and have connected clients get assigned IP addresses properly, but it then blocks access to the web. In other words, any requests that would need to go via the home server's wireless link don't get sent there.

Is there a way to selectively decide which DHCP server to use (either the home server or the router)?

Or can anyone think of a better way of doing this altogether?

I've got isc-dhcp-server installed and running.

Here is /etc/network/interfaces:

# The loopback network interface
auto lo
iface lo inet loopback

# the network for multicasting
auto eth0
iface eth0 inet static
        address 10.0.0.1
        netmask 255.255.255.0
        gateway 10.0.0.1
        broadcast 10.0.0.255

# the web connection
auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

And /etc/default/isc-dhcp-server:

INTERFACES="eth0"

And /etc/dhcp/dhcpd.conf:

default-lease-time 600;
max-lease-time 7200;
option subnet-mask 255.255.255.0;
option broadcast-address 10.0.0.255;
option routers 10.0.0.254;
option domain-name-servers 10.0.0.1, 10.0.0.2;
option domain-name "musicnet";

subnet 10.0.0.0 netmask 255.255.255.0 {
        range 10.0.0.10 10.0.0.100;
}

Thanks for reading!

0

Turns out I just had to remove the lines

        gateway 10.0.0.1
        broadcast 10.0.0.255

from /etc/network/interfaces. It then passes requests it doesn't know about on to the main router on the WiFi interface. Note however that the clients connected by wire don't get internet access with this, but this isn't much of an issue for me so I don't really care.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.