0

I started using Ubuntu (12.04) a month or so back, I've not done much with it so I have only a few important files (particularly my Thunderbird profile). Yesterday I tried to upgrade to 14.04; the install seemed to go OK but after the restart my screen shows garbage (I suspect the video drivers were replaced by unsuitable ones). Because the screen is garbage I cannot access the system and hence not the files either. I need to get my Thunderbird profile back (I don't really care about anything else).

I tried to reinstall 12.04 but both the installation options wipe all my files. I abandoned that effort.

I have used the "Try Ubuntu" option from the live CD and (following a hint I found) I tried using gksu nautilus I could see the .thunderbird folder but my attempts to copy the profile failed with the message "Error copying file: Permission denied". I have tried changing the permissions on both the .thunderbird and destination folder (on a USB memory stick) with no success.

I would really like to get that profile back (I have a sentimental attachment to some of my emails!). Can anyone help?

It's probably obvious that I don't really know what I'm doing in Ubuntu so - please be gentle (in particular, I need detailed instructions if the use of the terminal is required)

Thanks in advance

  • I answered a question here: askubuntu.com/a/443791/72216, so it would not be appropriate to write a duplicate here, but I would attach an external drive, start from the live cd WITHOUT accessing the drive of the computer from the interface, but mounting it from the terminal, after you determine the locations of the external drive and your personal data on the computer (using the lsblk command) and copy it to the external harddisk as described in the link. – Jacob Vlijm Apr 20 '14 at 13:52
  • Jacob:Thank you for the link. It took me a long time to get anything to work (my ignorance and, possibly, the form of my filestore) but I did get something in the end. But not the contents of (it appears) ANY hidden folder including the .thunderbird folder where the profile is to be found. I assume that it's a permission issue (as the error message says "Cannot open .... Permission denied") ie the same sort of problem I mentioned in the original request for help. – Eric Apr 20 '14 at 16:33
  • Eric, did you copy the whole personal folder? The .thunderbird folder really should be in it, that is not a permission issue. – Jacob Vlijm Apr 20 '14 at 17:16
  • also: did you ls -a? that should show the hidden folders/files as well – Jacob Vlijm Apr 20 '14 at 17:17
  • Jacob; I didn't know about ls -a (I did say I was new at this!) but I did do a properties on the .thunderbird folder (the name appeared) and it showed size was zero and number of included files as none (the same goes for a number of other hidden files). Sorry to say, your method didn't work (for me) but I did learn something about manipulating the filestore in a terminal (when you're as ignorant as me, it's easy to learn!) . Thanks for that – Eric Apr 20 '14 at 21:00
0

Use 'Try Ubuntu' to copy your ~/.thunderbird folder. Open Nautilus as root:

sudo nautilus

You should be able to copy files into a pendrive.

  • enedil: I tried your method originally (it looks simpler than Jacob's) but got a mess of error messages and stopped (I've been taught that error messages should be acted upon). But I decided to give it another go and ignore the error messages (I don't always listen to my teachers!) and in spite of apparent dire warnings (more error messages) something got copied across (using a copy/paste method rather than the earlier drag and drop method). The size of the folder is consistent with an earlier version of the profile so I live in hope. A stiff drink and I'll wipe my system .... Thanks Eric – Eric Apr 20 '14 at 16:48
  • After "importing" the profile into Thunderbird I got a message relating to security issues with a hint that it was the file permissions that were wrong. Selecting Properties on the .thunderbird folder and giving myself full read/write permissions (apparently) got everything working OK. Fingers crossed. Again, my thanks Eric – Eric Apr 20 '14 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.