11

So I just installed Ubuntu 14.04 tonight and I'm having this weird issue with my mouse and window focus.

I can't seem to click on any Unity Launcher icons. More over I can't click on unfocused windows to bring them to the front. It doesn't work.

I don't know how better to explain this. It is seemingly random when I can click on something inside a window. I can't even click on the "X" button to close or the title bar to move the window around most of the time. What's causing this behaviour?

I really want to start using Ubuntu as my main desktop but I've always had weird issues like this when I would test out a release. In a VM I don't have problems but after a real install I get problems.

Edit: Some more information, my mouse is a USB RAT5 gaming mouse. Not that I think it's the physical mouse that's broke...and the pointer doesn't freeze or anything. I just can't click on anything the majority of the time.

  • This exact behavior happens for me in 15.04 with my wired AZZA mouse (never buy that brand!). Restarting helps. Oddly, if by luck I can get to the Mouse Settings, it recognizes my that mouse buttons click and scroll wheel scrolls, but I can't close the window or click anywhere else! – jvriesem Sep 4 '15 at 16:01
  • Also a problem with some touch pads. – nsandersen May 16 '17 at 19:24
7

So I kept looking around and the problem seems to have been the type of mouse I have. I found a thread on the Ubuntu forums by a user with a similar mouse having a problem that sounded like mine. In the thread it was suggested to (create and) edit the /etc/X11/xorg.conf files with the following:

Section "InputClass"
    Identifier "Mouse Remap"
    MatchProduct "Saitek Cyborg R.A.T.5 Mouse"
    MatchDevicePath "/dev/input/event*"
    Option "ButtonMapping" "1 2 3 4 5 6 7 2 9 10 11 12 0 0 0"
EndSection

And then I restarted my computer.

I have RAT5 gaming mouse and the use from the thread has the RAT7 gaming mouse. It has been a day since I implemented the fix and there have been no problems. Didn't bother looking into why it was buggy but I know the above configuration fixed it.

Thread: http://ubuntuforums.org/showthread.php?t=2152976

  • 1
    /ect/... should be /etc/... (i couldn't update only 1 char, (minimal 6)). – Rudger Aug 19 '15 at 11:07
1

A search for a similar problem brought me here. Left mouse click doesn't work anymore, neither on the mouse itself nor on touch pad. In my case it is a matter of a bluetooth mouse.

My solution was to remove the mouse from the list of paired bluetooth devices (Dash → Bluetooth), switch off the mouse and re-pair it after a reboot.

1

I had this on 16.04 with a laptop and a USB mouse connected. USB mouse didn't work. Clicking once on the laptop's touchpad got the mouse's buttons to work again.

  • This worked for me with 14.04 and USB microsoft mouse. Even a reboot didn't fix the issue but your answer did! Thanks. – Champ Jun 20 '16 at 17:56
1

I found a solution to similar focus problem. A part of it was that mouse focus remained locked to one window but keyboard focus was in another. I fixed it by running:

sudo apt install wmctrl
xfconf-query -c xfwm4 -p /general/click_to_focus -s true 
wmctrl -R WindowName 
xfconf-query -c xfwm4 -p /general/click_to_focus -s false

Here are the links to original answer and bug report.

0

I had this problem with a wireless mouse on an Asus laptop. My touch pad, that I prefer not to use, was actually doing the same.

I tried a bunch of things, but in the end what fixed it was to unplug the usb receiver for my mouse, and plug it back in. Everything back to normal.

Not even a full restart did the same.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.