3

I recently upgraded to Ubuntu 14.04 LTS from 13.10. I had installed the earlier version using WUBI. I am receiving the following error on booting Ubuntu with the latest kernel 3.14

Serious error while checking for the disk drive for /

The follow up says either to ignore, skip mounting or the manual recovery. I can boot into Ubuntu 14.04 using the previous kernel version 3.11 in the advanced options specified in the boot options of Ubuntu. I have run the fsck on the root.disk and it says the disk is clean.

  • Have you tried boot-repair? – user269370 Apr 20 '14 at 2:38
  • 1
    boot-repair doesn't seem to work for Ubuntu 14.04. I tried using the live disk to install but it says that the package was not found. – hmehra Apr 20 '14 at 2:55
  • 1
    Edit /etc/sources.list.d/yannubuntu-boot-repair-trusty.list (I think its called) and change trusty to saucy, then sudo apt-get update and sudo apt-get install boot-repair. – user269370 Apr 20 '14 at 3:28
  • I would recommend boot-repair-disk, as it is handy to have around. – user269370 Apr 20 '14 at 4:05
  • 1
    Found the solution here: link – hmehra Apr 26 '14 at 5:06

Browse other questions tagged or ask your own question.