8

I have a working zpool and dataset set on my home server. I want to setup NFS to access ZFS over my home network on my Mac.

On the Ubuntu side, I have...

  • # apt-get install nfs-kernel-server
  • # zfs set sharenfs=rw=@192.168.0.0/24,insecure tank/documents
    • should allow 192.168.0.0 - 192.168.0.255
    • insecure is needed so the mac connects on ports bigger than 1024
  • # zfs share tank/documents
  • # service nfs-kernel-server start
    • commented out && grep -q '^[[:space:]]*[^#]*/' $export_files in /etc/init.d/nfs-kernel-server because I can't start the server with an empty /etc/exports/ file
  • # showmount -e to verify directory is mounted

The output of showmount -e is this.

Export list for ubuntu1404: /tank/documents *

On the Mac side, I have...

  • $ rpcinfo -p 192.168.0.3 to verify NFS is visible on the network
  • $ mount -t nfs 192.168.0.3:/tank/documents /Users/me/Remote

This last step is where I'm stuck. I keep getting "Operation not permitted".

I've been reading around, but I've only found old tutorials that use NFS Mounts from Disk Utility. Does anyone have any up-to-date tutorials?

2

Figured it out!

I must have the mount syntax wrong. I tried connecting in Finder and it worked!

enter image description here

1

Mounting requires administrative privileges. Try using sudo like this:

$ sudo mount -t nfs 192.168.0.3:/tank/documents /Users/me/Remote
0

To answer your question though, "Operation not permitted" is what you will see when there is already a mount attached to the named folder "/Users/me/Remote"

Using the Finder instead works fine, because it will instead mount the remote under /Volumes and not introduce that conflict.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.