4

I am using xubuntu and I upgraded from 13.10 to 14.04 today.

Now, when I close my laptop and I reopen it it show the login screen (as normal). When I enter my credentials, it show a black screen. I must to push the start button of my computer to show the login screen again and reenter my credentials.

I see my desktop but I think it restart the session. All my applications are close.

When I put my laptop in standby with the menu, it works perfectly.

Is there a solution?

1
  • Try to suspend by Menu>Close Session>Suspend then close the lid. – user287785 Jun 2 '14 at 18:45
6

A bug has been filled; check this link, and as you can see from that link, the bug is now labeled as "Fix Released". If it still isn't included in any automatic update, post number 91 has directions that fix the issue.

Also, some report that if you disable "Lock on suspend" in the "Light Locker Settings" screen, and then manually lock the screen from the terminal with:

light-locker-command -l

and then suspend by closing the lid, it resumes fine.

Alternatively you could change back to xscreensaver.

3

I ran into a similar issue. I can't remember where I found this solution, but someone mentioned that it was a conflict between xfce's power manager and systemd.

The person suggested the following:

  1. Open /etc/systemd/logind.conf in your editor of choice

    sudo vim /etc/systemd/logind.conf

  2. Adding the following line

    HandleLidSwitch=ignore

  3. Save and exit
  4. Restart

Anyhow, It worked for me. Hopefully, it works for you as well!

0

I had the same issue. It was fixed by opening Xfce Power Manager and changing When laptop lip is closed from Lock screen to Suspend for On battery and Plugged in options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.