8
  • Ubuntu Gnome 14.04

When locking the screen, my monitor/screen turns off immediately.

I don't want that to happen immediately, more like after 30 minutes or so. Is that possible?

3

This is not possible anymore in Gnome 3. You would have to execute gsettings set org.gnome.settings-daemon.plugins.power idle-dim-time [seconds] (possibly as lightdm as this is the user who runs the lockscreen) however this key doesn't exist anymore.

A possible workaround Khurshid mentioned is to install XScreenSaver (and set the timeout from there):

How can I change or install screensavers?

6
  • 6
    Really? Wow. :/ For the lack of a better word, this behavior is kind of stupid. – henry Apr 20 '14 at 7:23
  • @henry I am astonished too.. my old CTR monitor keeps turning off and that will surely lower its life that is already not that long... I need a patch to fix this lack of option... – Aquarius Power May 25 '14 at 1:29
  • @Louis, there is a iddle-dim that was checked, I unchecked it and it didnt seem to work; but after I checked it again, now my monitor will dim but it will not turn off! it was iddle for about 20min and the monitor was still on! I think this is a buggy behavior that works somewhat fine for me, but being buggy, any surprise can happen later... – Aquarius Power May 26 '14 at 22:30
  • I experienced something like this too (I don't remember what I did but the dim was gone). However it seems to have reset itself unfortunately. – Louis Matthijssen May 26 '14 at 22:36
  • the monitor is being turned off again :(, I will try the xscreensaver option, but I run games on "X :1" and I wonder if I can have 2 instances of xscreensaver working without one bugging the other? lets see what happens :) – Aquarius Power May 28 '14 at 3:51
0

This extension, "unblank", appears to work, I have only had it working for a minute now but my test shows that it keeps the display from turning off after pressing super + L.

https://extensions.gnome.org/extension/1414/unblank/

-1

I have a fresh installation of Ubuntu GNOME 14.04 on a new machine I got, and I have set the power to dim after "inactive for 30 minutes"

When I lock the screen it does not turn off for 30 min. However, if you don't manually lock the screen, it will turn off when your power settings have reached their limit (i.e. 30 min set time)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.