3

I try and try and try but ubuntu 14.04 is not recognizing my flash drive. It's a Kingston Datatraveler which has never caused me any problems before until now. Anybody know what to do?

5
  • Install Ubuntu 13.10 and be glad for it. Ubuntu 14.04 is still a work in progress.
    – Taz D.
    Apr 19 '14 at 20:16
  • One year later, I've just bought 4 DataTraveler Kingston G4 keys and none of them will mount in Ubuntu 14.04LTS.2. If anyone knows why, I'd love to see an answer to this question.
    – Scaine
    Apr 6 '15 at 13:44
  • I also have the same issue, when using it in a 3.0 USB. Jul 15 '15 at 18:17
  • Same issue here as well, in 2019. Sep 28 '19 at 14:01
  • I found out with dmesg | tail that the device somehow gets disconnected. Sep 28 '19 at 14:16
2

I fixed it. I tried the advice of pushing the USB in slowly. That didn't work.

What did work was pushing it in very slowly in a timed manner. Here is how:

I used dmesg -wH which keeps live updating dmesg in your terminal.

And right at the moment where Ubuntu said that it recognized it. I stopped pushing it in any further. Weirdly enough, this is as much a skill as learning how to use a small screwdriver or a semi-complex game controller combination in a video game.

My Kingston Datatraveler mounted. It did not mount by pushing it in slowly, but by pushing it in very slowly and immediately stopping when dmesgh said: "USB Mass Storage device detected"

1
  • wow! it really worked for me, thank you so much
    – nino_701
    Jan 24 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.