I've tried suggestions for solving this dealing with 13.10, but they don't seem to work. Hard refresh of the page doesn't remove the error. PHPMyAdmin has a box at the bottom indicating that the mcrypt extension is missing, even though it is installed for php.

How do I fix this?

  • extension=mcrypt.so did the trick for me ! Thanks ! – user292297 Jun 10 '14 at 16:40
  • 1
    sudo php5enmod mcrypt <br/> That is ok to me. – Mike Jul 28 '14 at 20:05
  • Ran into this problem earlier today, so I tried the recommended solution but was still seeing the error, so I decided to reboot and, wouldn't you know it, voila. – nburr Oct 14 '16 at 19:04

This is a reported bug. I had the same issue, found the answer here on ubuntuforums, so all credits goes to SeijiSensei:.

1) The mcrypt.ini file in /etc/php5/conf.d needs to be copied or symlinked to /etc/php5/mods-available:

cd /etc/php5/mods-available
sudo ln -s ../conf.d/mcrypt.ini . 

2) Activate the module with sudo php5enmod mcrypt.

3) Restart your web server: If using Apache, it's like this: sudo /etc/init.d/apache2 restart

Then log into the PMA, the issue will be fixed.

  • I followed these instructions exactly; the mcrypt extension message is still at the bottom of the page when I log into phpmyadmin. – Adam Jun 4 '14 at 20:55
  • @Adam have you restarted your web server? – Arda Jun 4 '14 at 21:14
  • I have; in fact, I restart my web server every time I reboot my computer, which is often, as it is a laptop I use for classes. – Adam Jun 7 '14 at 17:38
  • Weird, have you got any errors during these steps ? I'm using exactly this way, and I don't have the issue anymore. – Arda Jun 8 '14 at 20:59
  • No errors in any of the error logs for Apache. The solution I selected works, but I admit I don't know enough about what's happening to understand why your solution wouldn't work for me. It may just be that I have something of a non-standard setup. – Adam Jun 8 '14 at 23:00
up vote 5 down vote accepted

The fix that worked for me was relatively simple:

The solution: add the following line to the /etc/php5/apache2/php.ini file:

extension=mcrypt.so

This line causes the mcrypt extension to be loaded automatically when the server restarts. I don't know why Arda's instructions didn't accomplish the same thing in my case, but I think it might have something to do with upgrading from earlier versions of Linux.

protected by Community Jul 28 '14 at 20:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.