Fresh install of Ubuntu GNOME 14.04 with 3 displays (fglrx driver). I can correct the screens order in System Settings / Display but it is not saved when I close the session and reopen it.

Screens order in GDM is also wrong. Copy/pasting the .config/monitors.xml file into /var/lib/gdm/.config/ doesn't change anything.

Does anybody have an idea ?

closed as off-topic by Lucio, Braiam, user117103, Eric Carvalho, Avinash Raj May 18 '14 at 23:23

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Lucio, guntbert, Eric Carvalho, Avinash Raj
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I have the same problem. I use the Nvidia 331 Driver and no matter what Tool I use, the Display order always changes after a restart. So it Using a xorg.conf doesn't change anything. – user271095 Apr 19 '14 at 18:33
  • I have the same issue as well with a fresh (clean) install. All that was preserved was the /home partition. / was wiped completely. – Dillmo Apr 19 '14 at 23:54
  • same problem, it is every time gnome shell (re)starts. nb: no problem with unity desktop on ubuntu 14.04 – mikakun May 16 '14 at 13:47
  • i've reposted the question as not satisfied with current answers askubuntu.com/questions/467777/… – mikakun May 16 '14 at 14:27
  • Apparently a reported bug, bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/…, but I don't understand the problem. How are the screens not in order? – Braiam May 16 '14 at 21:00
up vote 32 down vote accepted

I have the same issue

seems like gnome-settings-daemon is not loading monitors.xml at startup

my work around is to run this command

pkill -9 -f gnome-settings-daemon

as a "Startup Application"

i have documented this in my ubuntu 14.04 update and problems post

not sure if there is a better solution

  • Works great ! Thanks for this workaround. I hope they will find the root cause since GDM has also the same problem. – chewiiie Apr 21 '14 at 11:02
  • +1 mate I just googled clicked and solved , awesome ubuntu community – billybadass May 11 '14 at 0:44
  • It still doesn't save the monitor setup for me, but it solves some other display problems. I need to explicitly add r (restart), though, to the end of pkill -9 -f gnome-settings-daemon. – Stefan van den Akker May 13 '14 at 12:24
  • This creates another problem in my case, makes the first desktop unusable (like it doesn't refresh and keeps shadows of closed windows in it) , any other options? I know yesterday there was a new LTS version released, but since this is a problem for two years at least i'm amazed at no bug-fix in part of ubuntu devs... – SomeNickName Apr 22 '16 at 15:03

Looks like a bug to me. If you'd like to see it corrected I would suggest that you mark on the official report that this bug affects you.

There is one more workaround: Link to article

It basically says that ~/.config/monitors.xml is not applied on startup. So the author created a script which basically does something like this:

xrandr --output LVDS --pos 1920x0 --output CRT1 --pos 0x0

...and adds this to Gnome startup programs.

  • you can also use arandr to create those monitor config shell scripts, but the problem is that the bug occurs at gnome-shell start which doesn't launch the app in the startup list...so i've re-asked the question askubuntu.com/questions/467777/… – mikakun May 16 '14 at 14:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.