21

I just installed ubuntu 14.04 and the mouse is now flickering on one of my two screens. The other screen doesn't have any flickering. I was previously using ubunutu 13.10 without any issue.

  • If I disable the screen that is working properly, the second screen stops flickering and starts to work properly.
  • If I disable the screen that is flickering, the other screen continues to work properly.

I already tried the solutions found here:

Here is what my display settings look like:

Display Settings

I'm using the X.Org X Server - Nouveau display driver from xserver-xorg-video-nouveau (open source) driver. If I try to switch to an proprietary nvidia one, and click the Apply Changes button, it just starts and takes for ever to complete, changes seems to never apply.

Here is what outputs xrandr:

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
VGA-1 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080      60.0*+
   1680x1050      59.9  
   1280x1024      75.0     60.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     60.0  
   720x400        70.1  
HDMI-1 disconnected (normal left inverted right x axis y axis)
VGA2 disconnected
HDMI2 disconnected
DP1 disconnected
HDMI3 disconnected
HDMI4 connected 1920x1080+1920+0 521mm x 293mm
   1920x1080      60.0*+   50.0     59.9     30.0     25.0     24.0     30.0     24.0  
   1920x1080i     60.1     50.0     60.0  
   1680x1050      59.9  
   1280x1024      75.0     60.0  
   1280x720       60.0     50.0     59.9  
   1440x576i      50.1  
   1024x768       75.1     60.0  
   1440x480i      60.1     60.1  
   800x600        75.0     60.3     56.2  
   720x576        50.0  
   720x480        60.0     59.9  
   640x480        75.0     72.8     66.7     60.0     59.9  
   720x400        70.1  
DP2 disconnected
DP3 disconnected
VIRTUAL1 disconnected
  1920x1080 (0x4b)  148.5MHz
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock   67.5KHz
        v: height 1080 start 1084 end 1089 total 1125           clock   60.0Hz
  1680x1050 (0xa2)  119.0MHz
        h: width  1680 start 1728 end 1760 total 1840 skew    0 clock   64.7KHz
        v: height 1050 start 1053 end 1059 total 1080           clock   59.9Hz
  1280x1024 (0xa3)  135.0MHz
        h: width  1280 start 1296 end 1440 total 1688 skew    0 clock   80.0KHz
        v: height 1024 start 1025 end 1028 total 1066           clock   75.0Hz
  1280x1024 (0xa4)  108.0MHz
        h: width  1280 start 1328 end 1440 total 1688 skew    0 clock   64.0KHz
        v: height 1024 start 1025 end 1028 total 1066           clock   60.0Hz
  1024x768 (0xa5)   78.8MHz
        h: width  1024 start 1040 end 1136 total 1312 skew    0 clock   60.1KHz
        v: height  768 start  769 end  772 total  800           clock   75.1Hz
  1024x768 (0xa6)   65.0MHz
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0xa7)   49.5MHz
        h: width   800 start  816 end  896 total 1056 skew    0 clock   46.9KHz
        v: height  600 start  601 end  604 total  625           clock   75.0Hz
  800x600 (0xa8)   40.0MHz
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  800x600 (0xa9)   36.0MHz
        h: width   800 start  824 end  896 total 1024 skew    0 clock   35.2KHz
        v: height  600 start  601 end  603 total  625           clock   56.2Hz
  640x480 (0xaa)   31.5MHz
        h: width   640 start  656 end  720 total  840 skew    0 clock   37.5KHz
        v: height  480 start  481 end  484 total  500           clock   75.0Hz
  640x480 (0xab)   31.5MHz
        h: width   640 start  664 end  704 total  832 skew    0 clock   37.9KHz
        v: height  480 start  489 end  491 total  520           clock   72.8Hz
  640x480 (0xac)   30.2MHz
        h: width   640 start  704 end  768 total  864 skew    0 clock   35.0KHz
        v: height  480 start  483 end  486 total  525           clock   66.7Hz
  640x480 (0xad)   25.2MHz
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   60.0Hz
  720x400 (0xae)   28.3MHz
        h: width   720 start  738 end  846 total  900 skew    0 clock   31.5KHz
        v: height  400 start  412 end  414 total  449           clock   70.1Hz
2
  • Have you tried plugging the offending monitor in to a different screen card or port? What happens if you swap the physical screens around? Does the flickering stay on the same monitor?
    – Kyle
    Apr 15 '15 at 13:01
  • I tried yes. Flickering is always coming from the graphic card. Apr 15 '15 at 13:02

11 Answers 11

17

Changing the scaling factor from 1x1 to 0.9999x0.9999 did the trick for me

xrandr --output eDP-1 --scale 0.9999x0.9999
4
  • 1
    Wow! Worked perfect for me. I have a second Screen connected over USB using evdi-dkms/1.6.0+dfsg-1ubuntu2 . You are the man :)
    – GreQ
    Mar 5 '20 at 0:13
  • 2
    I had issues with top bar size, I tried with xrandr --output eDP-1 --scale 1.0001x1.0001 => Worked like a charm, no more flickering and scale if perfect :) Original issue occured when my 4k main screen is used with an external FHD usb-c screen
    – Jihel
    Apr 25 '20 at 11:33
  • It works! But my question raised, why?
    – sevenever
    Aug 22 '20 at 14:08
  • I thought it was because different frame rate, but this trick works. Got this on custom scaling on second monitor. Page on main WQHD display still tearing though. Nov 7 '20 at 15:29
2

I had the same problem when I connected my second display to the VGA port. Problem solved when I changed to DVI. I found other issue using Display Port with a VGA adapter. The system goes crazy and becomes unable to detect the resolution properly. Quite a mess.

1

Try connecting your monitor on the VGA port if possible. I have a laptop with 2 external monitors connected - one on the VGA port and one on the HDMI port. Hardware is NVidia Optimus. With the 2 monitors connected the mouse cursor flickers on the built in display (the HDMI display works fine). If I unplug the HDMI monitor the flickering on the built-in display stops. This is probably a bug with the open source nvidia drivers. Please tell us more about your hardware.

3
  • I have a Nvidia GeForce GTX 560 TI, maybe I should change drivers ? Apr 29 '14 at 9:47
  • Well, yours is a desktop system which makes a bit of difference.
    – sмurf
    Apr 29 '14 at 10:44
  • I would try connecting the monitors do different port types - DVI, VGA, etc, including the on-board VGA. Perhaps the HDMI connection causes the flicker, at least it looks like that on my laptop.
    – sмurf
    Apr 29 '14 at 10:46
1

Go to a terminal and type or copy & paste [ sudo apt-get install linux-source ] -- press enter, it will ask if you really want to install, just say YES.

Then in same terminal type -- [ sudo apt-get remove --purge nvidia-* ] -- OR -- [ sudo apt-get remove nvidia-current ] -- OR -- [ sudo apt-get remove nvidia-current-updates ] -- then shut down and reboot.

After reboot, your system will be using a generic driver, go to Software & updates (additional drivers) and click one of the NVIDIA binary drivers listed, you should have a couple to pick from, either (proprietary,tested) or (proprietary), I would not use the Nouveau display driver, it is a generic driver and does not give full function.

Click on one of the listed drivers and click apply changes in bottom right corner and allow that driver to install, after its done installing, reboot system. If the driver you clicked on works flawlessly your all set to enjoy, if you still have problems you need to compleatly remove that driver using the remove command as per above and try the other driver listed in your (additional drivers) box. The KEY is to completely remove any other driver that is in your system or you will most certainly have problems!

Just so you know, you can copy and paste all my sudo commands, they are correct :-) Do not use the [ or ] when copying or typing they are only for separation. I hope this has helped, so you can ENJOY using LINUX as much as I do.

1

I had this problem on 14.04 with a similar setup. I also, at some point, had a problem of text editing delay from one of my monitors.

I had two video cards: one with 1 DVI port, and the other with both a VGA and DVI port.

In the end, I determined my problem was that I was mixing video cards: I was using two DVI ports from two different cards. By instead using just one video card -- using the VGA and DVI ports from that one card -- all my problems went away.

0

Under your green monitor there is a Unknown monitor. Move the green monitor, select the Unknown monitor and disable it.

2
  • I tried to move the green monitor but I can't find any Unknown monitor to disable. Where should I look exactly ? Apr 28 '14 at 7:14
  • flickering mouse could be too ---> malware "animal" ??? May 4 '15 at 8:03
0

I don't have the same problem but a similar one.
In my case the display is touchscreen, I solved disabling the touchscreen as input:

  1. sudo gedit /usr/share/X11/xorg.conf.d/10-evdev.conf from the terminal
  2. Add Option "Ignore" "on" at the end of touchscreen section (inside it)
  3. Reboot
0

Have the exact same issue. Partially solved using solution in this bug report: Parts of the UI randomly flicker when moving the mouse

sudo add-apt-repository ppa:townsend/compiz-nvidia-refresh-test
sudo apt-get update
sudo apt-get dist-upgrade

At least now it doesn't flicker when I move mouse.

0

I've had this problem since Ubuntu 14.10, with similar setup. I just gave up on Unity and run the Metacity flashback session instead.

I like Unity, but I can't stand the cursor playing hide-and-seek.

0

I had the same issue with Lenovo P50 with NVIDIA graphics card. I solved by changing display configuration to discrete from hybrid. Now no flickering.

1
  • I recommend to edit this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on AskUbuntu.) May 14 '17 at 18:43
0

In my case I had the same issue. Two screens + NVIDIA card. The mouse was flicking on the build one.

I solved by running "Software & updates" application then go to the Tab "additional drivers" and select "Using NVIDIA (propietary)".

Reboot the computer and problem solved

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.