I've just install Ubuntu 14.04 (trusty) to give a test run as I need to use monodevelop I've also decided to install that too. Previously I'd installed monodevelop compiling it from scratch on my 12.04 with so much effort. And this time I thought it would be nice if I could do it the easy way, PPA.

So I added ppa:ermshiperete/monodevelop and tried:

$ sudo apt-get install monodevelop-current
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 monodevelop-current : Depends: monodevelop-4.0 (= 4.2.2-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I'm relatively new to PPAs so I'm not sure if I'm doing something wrong or there's a problem with monodevelop + 14.04?

  • Did you update(sudo apt-get update) the repositories after adding the PPA? – Avinash Raj Apr 19 '14 at 14:09
  • Yes I did, I even managed to install the mono-3.0 from that PPA (I tested it using mono -V). – Mehran Apr 19 '14 at 14:13
  • But it seems some later action of mine uninstalled it!! – Mehran Apr 19 '14 at 14:15
  • My bad, when I run mono -V it tell me the moon-runtime package is needed, and it did so from the beginning. – Mehran Apr 19 '14 at 14:22

It seems there's been a problem with the repository. Now, after one week, it is resolved without me doing anything new.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.