I have installed Ubuntu 14.04 LTS on my laptop.

Under the networking menu at the top, it is not showing any WiFi options.

How can I get Wifi working in Ubuntu 14.04 LTS?

I have a Broadcom BCM4311 WLAN card.

  • 1
    Please edit your question with the kind of wireless card you have: askubuntu.com/questions/14008/… – Jorge Castro Apr 19 '14 at 15:27
  • Please do what is in the accepted answer in the link below so we may see the information needed to help diagnose the issue. <askubuntu.com/questions/425155/…> – Wild Man Apr 19 '14 at 20:49
  • 1
    Look at this question. If it doesn't work, edit with detailed explanation of what happened in your case, also incorporate all the information that was asked in earlier comments. – Aditya Apr 20 '14 at 17:41
  • Problem solved until reboot, and go back after reboot, here result for 'iwconfig' command line: wlan0 IEEE 802.11bgn ESSID:off/any Mode:Managed Access Point: Not-Associated Tx-Power=19 dBm Retry long limit:7 RTS thr:off Fragment thr:off Power Management:off – user276302 Apr 30 '14 at 14:14
  • Just Suspend the system and then resume back in. This surprisingly solves the wifi issue! Worked for me [ubuntu 14.04 LTS x64 on Asus laptop] – Nagendra Rao Jul 23 '14 at 14:54

For Broadcom BCM4311,

sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source broadcom-sta-dkms

sudo apt-get install b43-fwcutter firmware-b43-installer

See here https://help.ubuntu.com/community/BroadcomSTA(Wireless)

  • That worked like a charm :) – user3551525 Apr 23 '14 at 8:09
  • My son's laptop finally worked with this. – Juanin Jul 22 '14 at 11:46
  • When the WiFi stopped working for some reason reinstalling the b43 packages did the trick for me: sudo apt-get install --reinstall b43-fwcutter firmware-b43-installer. – rkallensee Dec 5 '14 at 23:20
  • didn't work for me... bcm4311 on 14.04, still cant connect to wifi network – gap May 31 '15 at 0:24
  • it showing me firmware-b43-installer is already the newest version. but still not showing WiFi option. I'm using 14.04 version. ANy suggestion? – CoDe Jan 19 '16 at 6:31

you can go to

settings> Software and updates > additional drivers

you can get most of wireless/Graphics drivers. You can install any 3rd party driver software you require. Hope that helps!

  • 1
    this helped. open source driver was choosen, but this only works with proprietary. after choosing proprietary driver in this dialog, wifi worked again. thanks – emirc Aug 16 '14 at 22:22

If you're using a Broadcom (BCM43xx) wireless network card like me, this might help.

I connected the laptop using a cable and ran:

sudo apt-get install firmware-b43-installer   

to install the driver and then rebooted.

(It would be helpful to add your network card to the question.)


Maybe you faced a problem like me Network indicator disappeared.

A solution that works for me is here:


Simply speaking, try nm-applet at first, if you take back WiFi indicator, then add nm-applet to Default applications for LXSession.

  • @scoze the link is broken – Abdul Hameed Aug 3 '17 at 13:51
  • @AbdulHameed sorry, I fixed the link, try again – scozv Aug 4 '17 at 23:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.