~/Downloads/FTL$ optirun -vv ./FTL
[ 3180.543769] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 3180.544875] [DEBUG]optirun version 3.2.1 starting...
[ 3180.544894] [DEBUG]Active configuration:
[ 3180.544904] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 3180.544931] [DEBUG] X display: :8
[ 3180.544966] [DEBUG] LD_LIBRARY_PATH: 
[ 3180.545003] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 3180.545042] [DEBUG] Accel/display bridge: auto
[ 3180.545077] [DEBUG] VGL Compression: proxy
[ 3180.545111] [DEBUG] VGLrun extra options: 
[ 3180.545144] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[ 3180.545282] [DEBUG]Using auto-detected bridge primus
[ 3181.061842] [INFO]Response: No - error: Could not load GPU driver

[ 3181.061861] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 3181.061867] [DEBUG]Socket closed.
[ 3181.061887] [ERROR]Aborting because fallback start is disabled.
[ 3181.061891] [DEBUG]Killing all remaining processes.

The fact that Bumblebee is unable to find a library path is odd to me, since I only recently updated bumblebee.conf like so:

## Section with nvidia driver specific options, only parsed if Driver=nvidia
# Module name to load, defaults to Driver if empty or unset
# colon-separated path to the nvidia libraries
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path

My laptop using a Gefore GT 525M. All the modules appear to be in place:

~$ find /lib/modules/$(uname -r) -name 'nvidia*.ko*'
~$ find /usr/ -name 'nvidia_drv.so'
find: `/usr/share/doc/google-chrome-stable': Permission denied

And I have just updated Bumblebee. Is there some reason I'm unable to use Bumblebee to run programs on my video card?

  • 1
    new here, I was having the same problem, Bumblebee working well, then I installed a fresh ubuntu 14.04 and got the issue, this guide worked well for me muktware.com/2013/12/install-nvidia-331-bumblebee-optimus-cards/… (without the nvidia-settings) I tried broker's way but it made my gdm freeze just before the login screen (using ubuntu gnome). – Basier Apr 20 '14 at 16:07
  • Question: what's the difference between the 331 Nvidia driver in the official PPA and the one from xorg-edgers? Or is there none? Just don't want to add PPAs that might break things. – MowDownJoe Apr 21 '14 at 1:50
  • thank you very much for your workaround which finally worked for me on my hp envy dv6 laptop. But I had somehow an unknown display set as default, under gnome none of the menu bars did show up, which I could resolve by rightclicking and choose the screen background settings for being able to reach the rest of the system settings. Maybe this helps someone running into the same problems... – user272883 Apr 23 '14 at 7:07

Remove bumblebee and libvdpau-va-gl1

sudo apt-get purge bumblebee*  
sudo apt-get purge libvdpau-va-gl1

install nvidia-prime and nVida drive and nvidia-settings 319

sudo apt-get install nvidia-319 nvidia-settings-319 nvidia-prime

and install prime indicator

sudo add-apt-repository ppa:nilarimogard/webupd8 
sudo apt-get update
sudo apt-get install prime-indicator



|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.