9

I've just upgraded to 14.04 and I've got a problem with IBus pinyin input. While it is very-very nice that now I have a little floating panel on which I can switch between simplified and traditional characters, full/half width, and can reach the IBus Preferences; the pinyin dictionary seems to have broken. E.g. I can't even type such simple expressions like "ni hao" and "xie xie". Actually, I can't even type the "hao" (good) character alone, because "ha" (laughter) appears.

Probably I just have a problem with my settings, but I couldn't figure out what is it. Does anyone have an idea how to fix this problem?

1
  • 1
    A reboot seems to have resolved this issue. Though I still don't know why it appeared in the first place. After the upgrade, the "拼" icon changed to "Pi", but after the reboot it's changed back to a blue "拼" and it works. One other thing I did is that I selected "IBus" in the Language Support panel, as it was empty after the upgrade - again for unknown reason. – MegaBrutal Apr 19 '14 at 21:24
14

I found this post that fixes the same problem for me:

run ibus-daemon -drx

and possibly a restart after that.

5
  • Meanwhile I encountered the same problem on other machine and I found this command very useful! It even solved another kind of problem, when I couldn't even add pinyin as an input method as it didn't even appear on the list. Sidenote: I wanted to comment on your blog but I found no option to comment, neither any other way to contact. – MegaBrutal Apr 22 '14 at 22:53
  • @MegaBrutal thanks for your reminding, the comment module of the blog has been fixed :) – otm Apr 23 '14 at 18:44
  • I ran this fix, which didn't work at first, then tried ibus restart which also didn't fix it, then both manually flipped from double pinyin to full pinyin in the GUI settings and ran sudo ibus restart which fixed it, but I can't tell which one it was that fixed it... – adempewolff Sep 1 '14 at 8:03
  • This fixed my install on Crunchbang too – hoju Dec 18 '14 at 6:04
  • Also fixed my Ubuntu 15.10. Why is this broken by default? :-( – Ciro Santilli新疆棉花TRUMP BAN BAD Jan 29 '16 at 16:03
2

I have the same problem. I tried ibus-pinyin, sunpinyin and googlepinyin. The first two were broken. The third has a slow refreshing issue.

I think ibus is just not ready for Ubuntu 14.04 now. I tried fcitx, which is another input engine. It works well. Here is an article about it.

http://my.oschina.net/eechen/blog/224291

I assume you have no problem reading a Chinese web page.

1

As documented at Pinyin Joe try to replace ibus-pinyin with ibus-libpinyin:

apt-get remove ibus-pinyin
apt-get install ibus-libpinyin
0

The following worked for me :

#1: clean up
sudo apt-get purge ibus
sudo apt-get install ibus
#2: reinstall (1)
# Settings > Language support > Install/remove language > Chinese (trad/simp)
#3: reinstall (2)
sudo apt-get install bus-table ubuntu-desktop unity-control-center unity-control-center-signon webaccounts-extension-common xul-ext-webaccounts
1
  • Please do not execute "apt-get purge ibus"!! It might crash your Ubuntu installation: Ubuntu 16.04 LTS GUI went unusable after that, and I'd had to reinstall the whole OS today. And it all started with the pinyin input option answering the wrong chinese characters... – Jose Tepedino Sep 4 '17 at 2:02
0

This method works for me: go to Preferences > Pinyin mode, select 'Full pinyin' and 'Incomplete pinyin', and close. After that you need to open terminal and type:

ibus restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.