13

So I'm having a problem after installing Ubuntu 14.04 on my HP Pavilion dv6-3160sp.

The problem is that after the booting to ubuntu the mouse/cursor simply vanishes, and also if I try like right click it doesn't do anything, so it's not "invisible" I think.

But when I was "Trying Ubuntu" before installing I didn't find any problem, the cursor was normal.

The iso that I'm using it's the official "ubuntu-14.04-desktop-amd64".

I tested with the touchpad and a normal mouse, with no results.

I tried to use the command:

gsettings set org.gnome.settings-daemon.plugins.cursor active false

but nothing worked.

1
14

I was having a similar problem after switching users. I was able to get the touch pad to work by reloading the kernel module:

sudo modprobe -r psmouse
sudo modprobe psmouse
2
  • 1
    The solution is no longer functional on Ubuntu 14.04. Apr 12 '16 at 5:58
  • Works for me on 15.10 multiscreen (2 monitors + laptop screen). The cursor was invisible only on one screen and visible on the others, but it was changing from time to time so that i had to change the elements i was working on to on of the screens that displayed cursor. Thanks !
    – Snorky35
    Sep 16 '16 at 12:26
6

I had a similar problem - after a kernel update, the display comes up fine and the cursor is invisible though it does work - I can move things around if I'm very careful.

This was solved by simply logging out and back in.

1
  • this is my case too. I'm used to do most things without mouse (I use emacs and I start it with Super-3) so I wait long enough to notice that after like 2 minutes the cursor will appear anyway.
    – mariotomo
    Jun 8 '15 at 13:44
1

I had the same problem. You can fix it manually. Open System Settings > Displays. In the Displays window, you will see an Unknown monitor. Click it and disable it.

I found the solution from the following: Mouse cursor flickering and disappearing

While I am using 14.04 and the above link is for 13.10; it worked for me! ;)

1
  • "Click it" - how if you can not see the mouse cursor? Apr 12 '16 at 5:58
1

In certain cases, this issue seems to be related to a lightdm bug. Try running:

sudo service lightdm restart

1

Do following steps:

  1. Open terminal (Using the Dash or by pressing Ctrl+Alt+T)
  2. Update apt with the command:

    dconf reset -f /org/compiz/
    
  3. After that, run the following command to restart Unity:

    setsid unity
    
  4. To get back the default set of icons released Unity pain, run the following command, and then close the current session and log in again:

    unity --reset-icons
    

Now your desktop Unity and the effects of compiz should be back to the original settings.

1
  • Worth mentioning that unity --reset-icons will remove all the icons from your dash sidebar, and log you out
    – Hagai
    Nov 17 '16 at 8:46
0

I had this problem too - ubuntu-14.04-desktop-amd64 works fine in the try ubuntu mode. But after installing it (I did a "choose something else" option for my instal and re-used my old /home which is on a different partition). And my partial solution for this at the moment is to boot via "advanced options" at the grub prompt and then from advanced options choose "regular boot" (or something like that - forget exact wording). Booting warns you about some graphics drivers might need a full graphical boot and then you get to the log-in screen. And magically the mouse and keyboard work. Not a very satisfactory solution though.

0

I was having the exact same problem on my Thinkpad x120e after a fresh install of ubuntu-14.04-desktop-amd64 (64 bit Ubuntu).

What worked for me was to install the 32 bit version of 14.04 desktop. It's worth a shot at least and it doesn't take very long.

Hope this helps!

Not the answer you're looking for? Browse other questions tagged or ask your own question.