14

I upgraded my xubuntu installation to the new release, 14.04. This release includes a new light-locker, a great improvement if you ask me. The thing is that whenever I try to lock the session or when it locks automatically after some time, it stops (or pause) playback of music, for instance (I have just noticed this while having some music played in the background on youtube).

When I unlock the session it resumes playing instantly. I've looked for some options in the settings, but didn't see any. Also, I found this bug https://bugs.launchpad.net/ubuntu/+source/light-locker/+bug/1296456 which if I understand correctly fixes this situation in version 1.4.0. Sadly, this is the version xubuntu 14.04 ships with, but the problem still exists. What should I do ?

2
  • 1
    Thanks for this. After upgrade I could not get XScreenSaver to start on lock-screen, simply needed to disable light-locker in the settings dialog to let XScreenSaver take control.
    – user283057
    May 19, 2014 at 7:12
  • In my Xubuntu no solution works - i have added my user to the audio group, audio still stops. I dont have any of the options mentioned here xubuntu.org/news/screen-locking-in-xubuntu-14-04 in the light locker menu. Would anyone have a screenshot or else please? I have 16.04.3. Jan 21, 2018 at 16:01

3 Answers 3

15

Here is what xubuntu.org has to say about this:

[...] Currently, when locking, it is assumed you are either:

  1. in a public space of sorts (the desktop at home hardly needs locking) and have walked away from the machine
  2. using a system with more than one user

Stopping/pausing playback in both of these scenarios make sense.

However, this might be an annoying change for users used to having their music playback continue even when their session locks. If you don’t like this behavior, there are basically two solutions:

  1. Set light-locker to lock the session “When the screensaver is deactivated”
  2. Switch back to using xscreensaver
  3. Add your user to the audio group on your computer and music playback will continue also with light-locker

The first option is a good workaround, because it means that your audio-playback will continue when the screen has been blanked. However, when you wake up your computer, e.g. by touching the mouse, it will pause the music until you log into your session again. The third solution is mentioned last, because it is not advised to add a user to the audio group (read The Audio Group wiki page for a comprehensive explanation). However, as long as you are on a single-user system, this might still be an option for you. [...]

light-locker

Figure 1: Light-locker, by default, will lock out sound.

For those who choose workaround 2, here is how to remove light-locker and install good old xscreensaver:

sudo apt-get purge light-locker light-locker-settings
sudo apt-get install xscreensaver

After installation, a "Screensaver" icon will appear in the "Settings Manager" menu. Clicking it allows to configure xscreensaver.

xscreensaver

Figure 2: XScreenSaver

2
  • 4
    My opinion about this: A locker serves to prevent unattended computer input, not to switch off useful computer output. Xubuntu developers should not make presumptions about the whereabouts and use of any computer. They should solve this annoying regression by adding a "Computer in public space" toggle switch defaulting to historic Xubuntu behaviour. Aug 15, 2014 at 12:03
  • 1
    This is still an issue with Xubuntu 16.04! Above solution remains valid. Aug 8, 2016 at 15:59
2

I had the same issue. I went to the Light Locker Settings and in "Automatically lock the session" I changed it to "When the screensaver is deactivated". Music is now still playing when the screen goes blank. Seems though that it now takes longer to return to the lock screen.

UPDATE: Seems like I need to do two touches/keystrokes to activate the lock screen. When I click the mouse once, the musics stops, and it needs one keystroke more before the Light Locker appears. Annoying.

1
  • 1
    I think that the xscreensaver's behaviour is not possible with light locker, unfortunately. perhaps the team behind light locker will consider and add this feature in a future release.
    – misterjinx
    Apr 24, 2014 at 7:03
1

I also encountered the same issue with Linux Mint using XFCE desktop. What I did is to replace light-locker with cinnamon-screensaver (which is nicer than xscreensaver and gnome-screensaver).

sudo apt-get remove light-locker
sudo apt-get install cinnamon-screensaver

Then edit the for-loop in the file /usr/bin/xflock4 to add the command that triggers cinnamon-screensaver like below:

for lock_cmd in \
    "cinnamon-screensaver-command -l" \        # this is the added line
    ....

Not the answer you're looking for? Browse other questions tagged or ask your own question.