After installing Ubuntu 14.04, I installed compizconfig-settings-manager. Then I made a mistake and disabled the Unity plugin. After that, Unity (the dash and panel ...) are gone.

I can't even run the terminal now.

What should I do? How can I restore or reset it?


5 Answers 5



I had a link to home folder on my desktop. So I opened it and I went to /usr/bin/ from location bar. Then I started gnome-terminal.

In terminal I opened ccsm (compiz config manager) and enabled Unity Plugin again.

And now it works normally!!

What an awful weakness this is for a desktop OS, isn't it?

Shouldn't it have a default thing for these situations to run (automatically)?

  • 1
    I Agree, unity desktop is weak from my opinion, if we do a simple thing wrong unity will disappear and we need to figure out what was the cause of it. I think It's not fully reliable. Apr 19, 2014 at 9:02
  • 4
    You shouldn't blame Ubuntu when you break it with something that does not come with Ubuntu. If you want to blame anyone with that logic, blame CCSM. However, they did popup a warning that you were about to turn off Unity and shame on you if you said to do it without understanding the ramifications.
    – maddentim
    Mar 13, 2015 at 23:48

To get started, press Ctrl+Alt+T to open a terminal window if it didn't work restart and press Ctrl+i when ubuntu is loading and from there do this steps. When it opens, run below command to reset Unity and Compiz settings:

dconf reset -f /org/compiz/

After running the previous command, you need to run blow command to restart Unity.

setsid unity
reset unity

To get back the default set of Unity Launcher icons, run below command and then log out and back in.

unity --reset-icons

If you want to restore default icon theme, use Unity Tweak Tool which is available in Ubuntu Software Center.

  • I had a link to home folder on my desktop. So I opened it and I went to /usr/bin/ from location bar. Then I started gnome-terminal. I did what you said in this answer, but nothing changed! I restarted my system with sudo shutdown -r now, and nothing happened yet.
    – Rahmani
    Apr 19, 2014 at 8:50
  1. I've sshed from my host into ubuntu running via vmware.
  2. Changed directory to ~/Desktop. Made ln -s ~/ to create symbolic link for home folder.
  3. Then I've opened folder, found terminal application. Started ccsm and turned on plugin again.

I spent several hours, but finally got it to work. Ubuntu 14.04 Desktop, Nvidia card: FX 3800

First, do Ctrl+Alt+F1 and login with your username and password

sudo stop lightdm

remove your nvidia drivers and use your nouveau driver

sudo apt-get remove --purge nvidia*

sudo apt-get purge nvidia*

sudo apt-get install xserver-xorg-video-nouveau sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf_bkup

now install unity-tweak-tool since unity -reset is deprecated

sudo apt-get install unity-tweak-tool

sudo apt-get install -reinstall xserver-xorg-core libgl1-mesa-glx

nvidia drivers have some dependencies with ubuntu-desktop, I also did:

sudo apt-get install ubuntu-desktop

and reboot

sudo reboot now

now do again ctrl+alt+F1 and login

up to this point, some of the steps that are similar to other posts on this #issue ... but when I tried reset unity from shell:

unity-tweak-tool --reset-unity

I received this error:

error: Cannot autolaunch D-Bus without X11 $DISPLAY

which I could not get around it, so

I install gnome-desktop, which worked (could see the desktop icons)

sudo apt-get update sudo apt-get upgrade sudo apt-get install gnome-shell
sudo apt-get install ubuntu-gnome-desktop

now reboot and login, you will see a small circle icon on the right top side #of the username box, click on it and a menu will allow you select gnome, #(ubuntu unity is defaulted)

finally, once in gnome, open a terminal ctrl+alt+T and do

sudo dpkg-reconfigure xserver-xorg

sudo reboot

login to gnome again and open a terminal

setsid unity

reset unity

unity --reset-icons

dconf reset -f /org/compiz

unity-tweak-tool --reset-unity

this last step above will overlay unity on top of gnome enviroment but voila, now reboot and login to ubuntu unity and it should work, this did the trick for me:). The gnome unity overlay will disapear next time you login to gnome too. Maybe some of the steps above are not necessary but they didn't hurt either. How I got into this mess to begin with? Trying to install cuda toolkit. Hope this helps!


I had the same problem. I just had to remove my Nvidia graphic card with this command after switching to ttyl with Ctrl + alt + F1

Sudo apt-get remove  --purge nvidia*
Sudo apt-get purge nvidia*

And I install nouveau which happens to be the default graphic card.

sudo apt-get install xserver-xorg-video-nouveau
Sudo reboot to restart

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .