I wanted to remove "Amazon" from my 14.04 and tried to follow the instructions given here:

However, even after logging off and loggin back in, I see that I get the updates to "Amazon":

amazon updates

"Online search results" have been disabled in Security and Privacy settings. I even tried to remove it from the software center by using the button provided in the above question which says there is no package named unity-lens-shopping. And if I again try to remove unity-lens-shopping from the terminal using sudo apt-get remove unity-lens-shopping, unity-lens-home is selected and nothing is actually removed and I get the following output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'unity-scope-home' instead of 'unity-lens-shopping'
0 upgraded, 0 newly installed, 0 to remove and 29 not upgraded.

I just ignore the 29 packages to be upgraded, for now, should be unrelated(?)

Trying to remove unity-lens-home I get a E: Unable to locate package unity-lens-home error.

How do I completely remove the shopping app from 14.04 to stop receiving updates for this application?

  • Try to remove unity-scope-home by running sudo apt-get remove unity-scope-home Commented Apr 19, 2014 at 8:02
  • @AvinashRaj: Edited my answer to reflect that.
    – jobin
    Commented Apr 19, 2014 at 8:11
  • it's unity-scope-home not unity-lens-home Commented Apr 19, 2014 at 8:12
  • 2
    @AvinashRaj: It says that would remove ubuntu-desktop, unity, unity-scope-home from the system.
    – jobin
    Commented Apr 19, 2014 at 8:14
  • Maybe you're tired of this topic, but, this question is not a duplicate. They say they already tried the instructions in askubuntu.com/questions/192269/…. Also I can confirm it doesn't work in 14.04. I see the same issue attempting to remove unity-scope-home. Commented Apr 28, 2015 at 4:15

2 Answers 2


It seems I need to remove unity-webapps-common to remove the shopping lens, including amazon.

To remove unity-webapps-common, open the Software center and type "Amazon" and remove the application with the Amazon logo as the application icon or open a terminal using Ctrl+Alt+t and type:

sudo apt-get remove unity-webapps-common

The following command worked on my computer.

sudo apt-get purge unity-lens-shopping

if it doesn't work,

sudo apt-get purge unity-webapps-common
  • I had to remove unity-webapps-common to remove amazon.
    – jobin
    Commented Apr 19, 2014 at 8:20
  • Same here had to remove unity-webapps before it disappeared. Surprisingly my dash search is much much much faster. Good job muhasturk
    – Gadgetroid
    Commented Sep 4, 2016 at 21:45

Not the answer you're looking for? Browse other questions tagged .