I guess, there are plenty of duplicates of this question, but I didn't find any to be helpful in my particular problem.

My story is as follows: I was running Xubuntu 12.04 on a Thinkpad X40 which has an Intel 855GM graphics chip. On 12.04 suspend worked flawless. Yesterday I upgraded to 14.04 and this broke suspend. The problem is like this: I close the lid, the laptop goes to sleep. After some time I open the lid, the screen goes on and if I'm fast I can even start typing in the password. However some seconds later the screen switches off again, though I can hear that the system continues working. I can still switch to any TTY, only X has no graphical output. If I kill X from TTY, it starts again, I can login and then the system works as expected. In /var/log/Xorg.0.log I see following lines:

(II) AIGLX: Suspending AIGLX clients for VT switch
(II) AIGLX: Resuming AIGLX clients after VT switch
(II) AIGLX: Suspending AIGLX clients for VT switch

which exactly fits to my observations: On lid close the screen goes off, on opening the lid it goes on and then after some seconds off again.

Any thoughts on how to prevent X from switching off the screen after waking up?

Thanks for any input.

Bug reported: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1310038

As somebody pointed out in an answer that seems deleted now, a workaround is to switch off light locker.


Here are a few options to avoid or recover from the issue.

Temporary fix

In the main bug ticket there's now a fix which involves adding a PPA:

  1. Add the Xubuntu Developers PPA to get the new packages: sudo add-apt-repository ppa:xubuntu-dev/ppa

  2. Update package information and update the two crucial packages:

    sudo apt-get update && sudo apt-get install xfce4-power-manager light-locker-settings

    xfce4-power-manager-data will get upgraded at the same time

  3. Restart your machine.

To remove the upgrades and return your machine to it's state prior to testing

sudo ppa-purge ppa:xubuntu-dev/ppa

Temporary workaround

The easiest way to work around this bug is to disable lock on suspend in the light locker settings. Of course, this means that your machine will resume from suspend without a password.

Quick fix

If you end up in this situation you can get back to a working state (note that you'll lose your current session and a new one will be started) by:

  1. Switch to a virtual terminal: CtrlAltF1
  2. Restart lightdm: sudo service lightdm restart
  • 2
    Yep, I'm also following this bug already. :) Thanks for writing everything up though! – Photon May 24 '14 at 7:07
  • 1
    this did nothing for me personally. – Joshua Robison Oct 28 '14 at 0:15
  • If you don't want to clobber all of your processes running under X then pkill light-locker instead of service lightdm restart in the "Quick Fix" steps above. – Dzamo Norton Jul 28 '17 at 8:31

Go to settings, light locker settings, and ENABLE the "lock on suspend" button, that works for me, and the system ask for my password to log in, without problems. I prove this with and without ac energy


Only thing that worked for me was to disable the lock screen. Which in my case is fine, since the laptop is stationary. However this may be of little relief to those people who actually carry their laptop around


Solution that worked for me reproducible on multiple laptops:

  1. Start "Xfce Power Manager"
    1. Make sure that the setting "When laptop lid is closed" is set to "Lock screen" for "On AC" and "On Battery".
    2. Make sure that the option "Lock screen when going for suspend/hibernate" is enabled (on the "Extended" tab).
  2. Start "Light Locker Settings"
    1. Make sure that the option "Enable light-locker" is enabled.
    2. Disable the option "Lock on suspend" (if it's not already disabled)
    3. Enable the option "Lock on suspend" (again)
    4. Click on "Apply".
  • I don't have "Light Locker Settings", I have light-locker and light-locker-command but thanks anyway, I guess. – yPhil Jun 17 '16 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.