1

I installed the latest version of vmware workstation (10.0.2) in ubuntu 14.04 LTS and I have the following problem:

enter image description here

I use the open source driver "Radeon" (Galium 0.4) and Mesa 10.1.0.

My graphics card:

glxinfo | grep OpenGL

OpenGL vendor string: X.Org OpenGL renderer string: Gallium 0.4 on AMD
RS780 OpenGL core profile version string: 3.1 (Core Profile) Mesa
10.1.0 OpenGL core profile shading language version string: 1.40 OpenGL core profile context flags: (none) OpenGL core profile
extensions: OpenGL version string: 3.0 Mesa 10.1.0 OpenGL shading
language version string: 1.30 OpenGL context flags: (none)
OpenGL extensions:


lspci -nnk | grep -iA3 VGA

01:05.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc.
[AMD/ATI] RS780D [Radeon HD 3300] [1002:9614]
Subsystem: ASUSTeK Computer Inc. Device [1043:834d]
Kernel driver in use: radeon 01:05.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] RS780 HDMI Audio [Radeon (HD) 3000
Series] [1002:960f]

glxinfo | grep -i render

direct rendering: Yes
GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, OpenGL renderer string: Gallium 0.4 on AMD RS780
GL_MESA_texture_signed_rgba, GL_NV_conditional_render, GL_NV_depth_clamp,
GL_NV_blend_square, GL_NV_conditional_render, GL_NV_depth_clamp,

I tried to install driconf and changed Enable S3TC texture compression...by default is No, and also edited the .vmx file, adding the line:

mks.gl.allowBlacklistedDrivers = "TRUE"

But it doesn't work.

I checked if this package is in my system:

libtxc-dxtn-s2tc0

I think it is a free implementation of the texture compression library for Mesa. This package is installed by default on Trusty.

Any help would be greatly appreciated

Best Regards.

2

Your Ubuntu video driver does not support 3D. You need to install the opensource driver or the ati catalyst driver

| improve this answer | |
0

I found the answer to this other question incredibly useful. Enable 3D HW acceleration on VMWare Workstation 10 on Ubuntu 14.04

The winning answer, https://askubuntu.com/a/537870/318507 which worked great with Workstation 12 on my Ubuntu 16.04 install.

| improve this answer | |
-2

Try

sudo chmod +x ./VMware-Workstation-Full-10.0.2-1744117.x86_64.bundle

This is to give execute permission to bundle file. Now you can run the file:

sudo ./VMware-Workstation-Full-10.0.2-1744117.x86_64.bundle
| improve this answer | |
  • The OP is having problems getting 3D support in VMware Workstation, not problems executing the installer. If you believe re-installing will fix the OPs problems I would suggest stating that more clearly in your answer. – please delete me Jun 22 '14 at 4:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.