My cat was recently laying on my computer when I was trying to edit the xubuntu menu using the Menu Editor application (menulibre). My cat messed around with some stuff so when I tried to go back into menulibre to try to fix it, it would not open. I got an error for the first two times that I opened it that said that it quit unexpectedly, but I can not get that again, so I can not say what it said. The rest of the times that I tried to open it, I got no error, so I opened up the task manager, and tried to open it again. I opened it, and it appeared in the task manager for a few seconds in red and then went away. So then I tried to open it from the terminal by typing menulibre and I got this error:

** (menulibre:2819): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-d2bt58fVXP: Connection refused
ERROR:/build/buildd/gnome-menus-3.10.1/./libmenu/gmenu-tree.c:4022:preprocess_layout_info: assertion failed: (!directory->preprocessed)
Aborted (core dumped)

Thanks in advance :D


I have tried restarting my computer multiple times but I have still not gotten a result.

1 Answer 1


First backup the menus

mv ~/.config/menus/ ~/.config/menus.bak

Then open menulibre and your problems are solved. :)

  • Still a valid solution in 2022!
    – Flatron
    Sep 21, 2022 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.