17

Could you please help me ?

On my old Ubuntu 13.10 I was able to run Juniper VPN (on Firefox only) using a workaround which requires you to install the missing 32libs and IcedTea (32bits).

However, I recently upgraded from Ubuntu 13.10 to 14.04 (both 64 bits) and my Juniper VPN does not work anymore because it fails during startup showing the following message:

"Please ensure that necessary 32 bit libraries are installed. For more details, refer KB article KB25230"

"Setup failed. Please install 32 bit Java and update alternatives links using update-alternatives command. For more details, refer KB article KB25230"

For some odd reason, it seems the 14.04 upgrade do not work anymore with the openjdk-7:386 and consequently the Juniper VPN as well.

Any ideas ? Thanks

  • Does Juniper not support OpenVNP? If so, you could use that. – don.joey Apr 19 '14 at 7:37
19

You could try the suggestion in this post: Juniper setup on 12.04

Update for 14.04 Trusty Tahr (64-bit)

First run with Network Connect on 14.04 resulted a failure and Network Connect just complained about missing 32-bit libraries. My NC version is 7.4R6. I did have all the libraries installed and openjdk-7-jre:i386 installed.

Digging a little bit deeper revealed that Network Connect is using update-alternatives listing to decide if 32-bit jre is installed.

/usr/sbin/alternatives command not found
Command = /bin/sh -c /usr/sbin/update-alternatives --display java 2>&1 | grep -v "/bin/sh:" | grep ^/ | cut -d " " -f 1 | tr " " " "

However it's looking update-alternatives from /usr/sbin/ and there seems to be no symlink pointing to the right directory like 13.10 had. So adding symlink to /usr/sbin/ helped.

$ sudo ln -s /usr/bin/update-alternatives /usr/sbin/

Just for completeness, as well as having to install a 32-bit JRE, I also had to follow the info here: http://itfuzz.blogspot.de/2013/11/juniper-network-connect-and-ubuntu-1310.html and run this command on 14.04:

sudo apt-get install libstdc++6:i386 lib32z1 lib32ncurses5 lib32bz2-1.0 libxext6:i386 libxrender1:i386 libxtst6:i386 libxi6:i386

I must already have done this on 13.10 as it worked then, but on 14.04 the Network Connect window just closed. This fixed the problem.

  • Nice ! It worked !!! Thanks !! – Max Ricardo Mercurio Ribeiro Apr 21 '14 at 2:05
  • @mike do you mind explaining what how you dug deeper into this issue? I'm interested in knowing how you determined that Juniper was using update-alternatives (strace?). I'm on 14.04 and went through this fix to no avail – jairo May 1 '14 at 19:31
  • You saved me. Your answer is the only solution which works! – Itai Ganot Jun 3 '14 at 9:15
  • I followed the directions but still couldn't get it to work, it would just die after one second. Turns out my problem was an encrypted home directory!!! Some issue with how it's mounted regarding "suid" keeps it from working. I had to make a softlink from my "~/.juniper_networks" to another location on an unencrypted partition. – Lee Dixon Jan 14 '15 at 20:22
  • This worked for 14.10 but unfortunately for 15.04 the application would launch but does not send traffic. The received bytes are always 0. any idea guys? – Akilesh Apr 25 '15 at 10:10
6

I just set up a VPN connect to juniper using MadScientist's msjnc script that wraps around a binary (ncsvc) from the juniper linux client .jar

The ncsvc binary does not require java at all, so this is somewhat the neatest solution I could find.

The script can be found here: http://mad-scientist.us/juniper.html

0

Due to some wrong upgrades, I couldn't launch vpn. Finally this blog helped me.

http://www.lyricalsoftware.com/blog/juniper-vpn-working-in-ubuntu-14-04-trusty/

  • 1
    the link is broken :( – Ievgen Aug 7 '16 at 19:18
0

In my case the following steps work:

  1. Install Oracle Java 8

    sudo apt-add-repository ppa:webupd8team/java

    sudo apt-get update

    sudo apt-get install oracle-java8-installer

  2. Download the tar ball of 32 bit Java 8 from here

download jre-8uXXX-linux-i586.tar.gz

XXX - version (in my case 131, change in following steps 131 to the version that you downloading)

  1. Move the file to /usr/lib/jvm/

    sudo mv /home/envy/Downloads/jre-8u131-linux-i586.tar.gz /usr/lib/jvm/

  2. Extract the file

    cd /usr/lib/jvm/

    sudo tar xvf jre-8u131-linux-i586.tar.gz

  3. Change it to root ownership

    sudo ls -ld /usr/lib/jvm/jre1.8.0_131/

    chown root.root -R /usr/lib/jvm/jre1.8.0_131/

  4. Update the alternatives link for Java

    sudo update-alternatives --install /usr/bin/java java /usr/lib/jvm/jre1.8.0_131/bin/java 10

  5. Ensure that the default Java version is still 64 bit

    update-alternatives --display java

    7a. If Java default changed to 32 bit version.

    sudo update-alternatives --config java

  6. Install the standard 32 bit libraries

    sudo ln -s /usr/bin/update-alternatives /usr/sbin/

    sudo dpkg --add-architecture i386

    sudo apt-get install libstdc++6:i386 lib32z1 lib32ncurses5 libxext6:i386 libxrender1:i386 libxtst6:i386 libxi6:i386

source here

protected by Community Jul 24 '14 at 14:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.