I toggle between writing in Japanese and English on my computer, usitng Anthy and iBus. I just recently installed Ubuntu 14.04 on two computers, and set up my language input options the same as I have for years, and for the most part it works fine and I have all the functionality I wan

The only problem is that on one of the computers, my laptop, whenever I switch to Anthy to input Japanese, this floating toolbar pops up just under where I'm typing'

anthy floating toolbar

I can' find any option for getting rid of this thing. It doesn't show up on my desktop computer, so I know it doesn't have to be there for Anthy to work.

How do I get rid of this toolbar?

up vote 2 down vote accepted

Go to Setup - IBus-Anthy either via the third button on the bar you want to get rid of, or via Dash > Text Entry > [single click] Japanese Anthy > [click on settings bottom right].

You can choose what parts of the menu should display next to your cursor, when Anthy is active, in the settings's General tab under Menu visibility on Status Icon. Uncheck all boxes (in your case Input mode, Dictionary mode, Preferences - Anthy) and the menu should disappear.

  • Thanks for this information. Sorry, though, I should have mentioned I'm using Gnome-Flashback. I don't seem to have a Setup - Ibus-Anthy anywhere that I can see. I was able to uncheck the options on Menu visibility on Status Icon, but the toolbar is still there. – Questioner Apr 19 '14 at 16:02
  • I had the same problem when updating to ubuntu 14.04 (with unity). For me it disappeared after unchecking these options and restarting Anthy. Setup - Ibus-Anthy is the name of the window, which is the preferences window for Anthy. If you managed to uncheck the boxes, I guess you found it. Can you check, whether the menu is still there after a reboot? – Earthliŋ Apr 19 '14 at 16:24
  • This might have worked. After a reboot, I stopped seeing the toolbar on my laptop. Oddly, I started seeing it on my desktop. In any case, I'm going to confirm my settings on both machines and then hopefully come back here to mark this as correct. – Questioner Apr 20 '14 at 12:27
  • If you're reading this in 2017 or later, you should probably try my answer instead. – Will Oct 6 '17 at 1:44

If you go to System Settings -> Text Entry and select Anthy, you can click the toolkit icon to reach the Anthy Setup dialog. Possibly (I don't really know) it includes a way to disable it.

The currently accepted answer (Earthliŋ's) is not correct - or at least not accurate anymore in 2017.

Whether or not the popup (misleadingly called the "property panel" by IBus) appears is not controlled by IBus-Anthy but IBus itself. The Menu visibility on Status Icon checkboxes in IBus-Anthy only controls what appears on the popup. Unchecking them all creates a zero-width popup, that seems to have the unfortunate side effect of breaking keyboard input conversion (e.g., zenkaku/henkaku) altogether.

The actual solution to OP's problem is simply to open IBus Preferences (right-click on the IBus task bar panel icon), and at Show property panel: to select the Do not show dropdown option.

  • The question asks about ubuntu 14.04. Maybe you could add what version of ubuntu your answer refers to. 17.04? – Earthliŋ Oct 6 '17 at 8:48
  • @Earthliŋ Honestly, none. I use Arch. Just found this question because I had the same problem as OP. I can't imagine Ubuntu doing anything particularly distribution-specific with IBus/Anthy though? – Will Oct 6 '17 at 12:37

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.