12

Everytime I reboot, I've to turn off and on hotcorners from unity-tweak-tool. Other wise hot corners don't work. Any fix??
Thanks in advance!

  • This settings in in normal System Settings as well. Have you tried adjusting it there? Otherwise, it might be a bug. In that case, you should report it on Launchpad.net. – Jo-Erlend Schinstad Apr 19 '14 at 5:19
  • Where exactly is this setting in normal System Settings? I worked around this bug in 13.10 like mentioned here askubuntu.com/questions/309301/… but in 14.04 it really messes up my desktop when i hit a corner. – user27401 Apr 19 '14 at 15:50
  • Same problem here. Is there any fix by now? – akkie Apr 24 '14 at 8:01
  • Same issue here – craigsmith86 May 25 '14 at 13:27
2

Same happended to me. But, first of all, after I upgraded to 14.04 I didn't have this problem, it happened like two days ago after an update. The point is that I solved it by applying a solution I once knew worked for 13.04. Its the following:

  • Run the dconf-editor:

    $ dconf-editor
    

    (if you don't have it install it by: sudo apt-get install dconf-tools)

  • In the pop-up window go to the list on the left and open "core", which you find in the following order:

    org -> compiz -> profiles -> unity -> plugins -> core

  • Once selected "core", on the right find a key named "active-plugins", and change the order of the last three entries in the "Value" field, so that the last ones are 'unityshell', 'expo' and 'scale'. For ease of the procedure, delete all the entries in the "Value" field, copy the following lines and paste them in the "Value" field:

    ['core', 'composite', 'opengl', 'copytex', 'compiztoolbox', 'resize', 'mousepoll', 'wall', 'widget', 'grid', 'imgpng', 'snap', 'move', 'place', 'regex', 'vpswitch', 'animation', 'session', 'unitymtgrabhandles', 'workarounds', 'fade', 'ezoom', 'unityshell', 'expo', 'scale']

  • Reboot.

  • I followed these instructions and now I have a blank screen. How can I undo this by command line? – Sean Lawton Oct 31 '14 at 16:34
  • My entire computer is useless now. I have to ctrl-alt f1 to even get a terminal. I tried to follow unity and dconf reset protocols but they do not work without x11 active. please, how do I reset this without x11 active? – Sean Lawton Oct 31 '14 at 16:55
  • following askubuntu.com/questions/476930/ubuntu-desktop-does-not-load I was able to fix it. – Sean Lawton Oct 31 '14 at 17:24
  • There is some similar discussion/rationale for this approach here, but after the comments above I'm reluctant to try this. Has anyone seen this approach work for them? – Drew Noakes Dec 16 '14 at 13:56
2

Hi guys I am very new to Linux (less 24 hours) but I've already met with this problem and found a solution.

Go to Startup Applications then ADD a new one, give it a name (doesn't matter what) and add this command:

compiz --replace

Then save. restart and enjoy.

Edit> doesnt work reliably, though.

2

in 14.04 for a work around what I did was write a bash script to set the hot corner edge valuse using dconf, but you will need to use dconf to find out what hot corner triggers you are using you need to install dconf-editor, using the tree-structure you can work out the paths.

#!/bin/bash
dconf write /org/compiz/profiles/unity/plugins/scale/initiate-edge "'|TopLeft'"
dconf write /org/compiz/profiles/unity/plugins/scale/initiate-all-edge "'|BottomLeft'"
dconf write /org/compiz/profiles/unity/plugins/expo/expo-edge "'TopRight'"
dconf write /org/compiz/profiles/unity/plugins/core/show-desktop-edge "'|BottomRight'"

For expo it didn't have | in front

Then I ran this automatically script after logging in, by adding it via "Startup Applications" you have to search for it in Unity Dash.

  • A good workaround for 14.04 ! – Kalamalka Kid Jan 18 '16 at 9:18

protected by Sylvain Pineau Sep 25 '14 at 9:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.