SOGOU (搜狗) is a popular Chinese input software. For Ubuntu 14.04, they worked with the team of Ubuntu Kylin to create a linux version of their software.

It's based on FCITX input software, which is developed by the FCITX TEAM on launchpad.

I installed it on my laptop with Ubuntu 14.04 without any problem, and it works GREAT!

enter image description here

But, I have a netbook at home, with Lubuntu 14.04 installed on it. And I want to enjoy SOGOU on it as well.

  • I added the PPA of FCITX TEAM : deb http://ppa.launchpad.net/fcitx-team/dailybuild-fcitx-master/ubuntu trusty main
  • I then ran apt-get update && install fcitx
  • I downloaded the SOGOU software from http://pinyin.sogou.com/linux/, and installed it (OK)
  • Restart, I choose FCITX as my input method, start it from commandline $fcitx (as it doesn't start automatically).

I'm now using FCITX, BUT SOGOU doesn't work. When selected, it's like using the regular keyboard (no chinese character).

I read this : https://wiki.archlinux.org/index.php/Fcitx_(简体中文)‎ and added this to .xprofile

 export GTK_IM_MODULE=fcitx
 export QT_IM_MODULE=fcitx
 export XMODIFIERS="@im=fcitx"

But with no help. So do you have any idea on HOW to make SOGOU PINYIN (搜狗拼音) work on Lubuntu 14.04 (LXDE)?

On the left Ubuntu 14.04, on the right LUBUNTU 14.04 (fcitx app indicator) enter image description hereenter image description here

If I run $fcitx-qimpanel then it seems to improve on LUBUNTU, but I still cannot choose the SOGOU entry from the menu :

enter image description here

When I select the SOGOU entry in the menu, NOTHING happen. It's when I click on the fcitx icon that the message appears in the terminal.

gumeiren@gumeiren-N128:~$ fcitx (I first need to run fcitx, otherwise fcitx-qimpanel has no effect)
gumeiren@gumeiren-N128:~$ fcitx-qimpanel
gumeiren@gumeiren-N128:~$ MainController::init() 
QMetaObject::connectSlotsByName: No matching signal for on_checkBox_tab3_FontSize_toggled(bool)
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 152 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 148 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 152 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 152 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 152 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 154 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 152 missing '='
"系统词频: 20110527" 
"组词数据: 20110307" 
"编译时间: Apr 17 2014 07:25:54" 
void SystemTrayMenu::init() 
gumeiren@gumeiren-N128:~$ (WARN-1798 /build/buildd/fcitx- Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 150 missing '='
(WARN-1798 /build/buildd/fcitx- Invalid Entry: line 150 missing '='
  • What happens when you try to select the option in Lubuntu?
    – Seth
    Apr 19, 2014 at 3:12
  • Looks like you might be missing a library somewhere.
    – Seth
    Apr 19, 2014 at 3:18
  • I just added a screenshot of the terminal output. Apart from this, nothing happen, the English Keyboard is still selected.
    – Sulliwane
    Apr 19, 2014 at 3:19

4 Answers 4


As advised by the FCITX team on Launchpad:

  • I removed the PPA (deb http://ppa.launchpad.net/fcitx-team/dailybuild-fcitx-master/ubuntu trusty main)
  • I uninstalled fcitx apt-get remove fcitx && apt-get autoremove && apt-get update
  • I restarted
  • I reinstalled sogou_pinyin from http://pinyin.sogou.com/linux/ dpkg -i sogou_pinyin_linux_1.0.0.0011_i386.deb with many dependencies errors in the terminal.
  • I ran apt-get install -f to solve the dependencies errors.
  • And in a terminal as a regular user fcitx and after fcitx-qimpanel

And BAM! It works. So I should not have added the PPA I guess!

  • 你好! Confirmed working in Xfce 16.04, but I have to add fcitx and sogou-qimpanel %U to autostart to make the panel come up everytime I login. sogou-qimpanel is added by installation, but not fcitx. Oct 1, 2017 at 20:05

In 17.04 libopencc1 is not available, however libopencc2 is compatible with it.

Adapting suggestions from here:


sudo apt install libopencc2 fcitx-libs fcitx-libs-qt fonts-droid-fallback 
sudo dpkg -i sogoupinyin_2.0.0.0078_amd64.deb

Something like the above should work to install it (adjusting based on the latest deb version).

First time running it didn't show the suggestions when typing, changing the skin fixed this.


The major problem I met was that I used the English interface for the system.

As soon as I changed the language to Chiense.Sougou begin miraculously to work. It still works when I changed back to English.

But sadly, this Sougou is not the sougou I used on other gears : There is no double pinyin, either synchro with other devices.

I think I still need to wait until it is usable.

  • I confirm this on 15.04. I have installed chinese simplified and traditional ... sogou started to work only after I change the language to chinese and then reverted back to english Aug 13, 2015 at 9:49
  • Finally I didn't use it doesn't handle "double pinyin", otherwise I would be interested in putting together all the statistics of my typing...
    – lzj
    Aug 14, 2015 at 12:56
  • And for those who wonder what double pinyin is :) Sep 29, 2017 at 20:36

Installing Sogou Pinyin is relatively straight-forward and easy. I did it like this:

  1. Download and install Fcitx. You can do this using the terminal: sudo apt-get install fcitx.
  2. Download Sogou Pinyin from here. They have both 32-bit and 64-bit. You can install the deb package using the Ubuntu Software Center, or GDebi Package Installer. You can install any additional dependencies using sudo apt-get install -f.
  3. Logout from the current session and log back in.
  4. In the top panel, you should see a small keyboard icon. Sogou Pinyin should be installed and ready to use.

Sogou Pinyin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.