5

I just performed a clean install (not an upgrade) to Ubuntu 14.04 (64-bit, PC desktop ISO) on a PC that previously had Ubuntu 12.04 installed. Upon trying to restore my \home directory from a Samba server via Deja Dup, I got the error message:

Restore Failed: Software caused connection abort

Further investigation lead me to find that this is just a symptom of a larger problem. On my home network I have three Samba servers. Any attempt to use Nautilus to copy and paste any content between shared folders on those machines and local folders results in the same error message.

There have been two other threads exploring this same error message, plus one additional post with no replies.

The first thread - limited to SSH problems - was resolved by eliminating redundant IPs on the network. That is not my problem. It's a small home network, all IPs are accounted for. And this problem began immediately upon installation of Trusty Tahr. Minutes before it all worked well under Precise Pangolin. Also, my router reserves IPs by MAC address, so though I'm using DHCP on my Trusty PC, it's getting the same IP. No conflicts there. Finally, I reinstalled 12.04 as a test, and the problem went away. So IMO it's not an IP problem.

The other thread deals with file access issues. To test that possible problem I created a new local folder and chmod'ed 777 permission to myself. Then attempting to copy files between that folder and the SMB servers, I got the same error. So I assume the problem I'm seeing is not an access issue either.

Anyone have any idea what's causing this error? And how to fix it? Thanks.

5
  • Very same issue here. Can't copy anything through smb anymore since ubuntu 14.04 update. Apr 19 '14 at 19:51
  • If this is happening to you too Jan, IMO this is a bug, and not some oddity with just my machine. So there are likely a good number of other people with this problem. Hopefully some of them are filing bug reports. I've worked around the problems it's caused me by starting FTP on my servers. FTP works fine. It's SMB that 14.04 seems to have impacted.
    – scolley
    Apr 20 '14 at 14:40
  • I guess it is - it worked before the update. Apr 20 '14 at 18:20
  • 1
    Just logged the bug at Canonical bugs.launchpad.net/ubuntu/+source/nautilus/+bug/1312362 Apr 24 '14 at 19:41
  • And another one at Gnome - as demanded by Canonical bugzilla.gnome.org/show_bug.cgi?id=729010 Apr 26 '14 at 9:30
2

I found something quite similar. Only I can access some files and not others. In my case the problem is limited to the connection with gvfs (and here SMB only - it works well using AFP to another server). I used a workaround by mounting the shares manually or via fstab. Both worked for me.

Ingo

1
  • That works for me! To be a little more specific, I had to use mkdir to create a directory to serve as the mount point, and then - sudo mount -o username=,<username>,password=<password> //192.168.1.xxx/<shared-folder-name> /<mountpoint-directory-path-and-name>
    – scolley
    Apr 26 '14 at 16:15
2

This error message may appear after a samba connection has been idle (Bug #1321354).

Microsoft servers drop idle connections after 15 minutes. This behavior can be disabled by the following command as administrator (Article ID: 297684).

net config server /autodisconnect:-1

Alternatively, adding the following script to the gnome startup applications keeps the connections alive.

#!/bin/bash
while true
do
    ls /run/user/`id -u`/gvfs/smb-share:* &> /dev/null
    sleep 600
done

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.