So today I've decided install the new 14.04 (64bit) on top of the 13.10 (32bit) Ubuntu that I used to have dual boot with Win 7. So it gave me number of options to install the 14.04, one of them was to re-install Ubuntu without loosing my files and applications (where is possible). And when the process of the installation finished I was prompted to restart as usual, but this time the GRUB menu doesn't showed up to let me choose if I'd boot with Windows or Ubuntu, and it boots only with Ubuntu now. I've checked the partitions with Gparted and the Win7 is still there.

So, is there a way to make GRUB see the both OS again, and how?

Thank you in advance !

I just encountered the same problem after installing Kubuntu 14.04 on top of a (broken) 13.10. I found this tiny solution to recover the grub functionality:

Just open a terminal and enter

sudo update-grub
  • Hi, I don't think this alone will restore the ability to boot into windows. – NGRhodes May 20 '14 at 9:58
  • 5
    Well, it did. Actually, before I executed this command, grub wasn't showing at all upon boot. Instead, (k)ubuntu was booted directly. When I executed the command, it gave me an output what OSes were found. Since then the boot menu appears and windows is listed there. – Arne. May 22 '14 at 11:35
  • This is the answer I've been hunting for. Simple, and it worked. Thanks a lot. – Steve McGuire Aug 3 '14 at 20:46
  • Even this worked for me on Ubuntu 16.04 LTS – RIYAJ KHAN Sep 3 '16 at 14:49
  • Agh, I was going to do this but it seemed too simple. +1 for making me feel dumb! – Nic Hartley Sep 14 '16 at 4:21
up vote 6 down vote accepted

Booted from live USB with the version on my Ubuntu which is installed on my PC and installed Boot Repair by entering the following commands in terminal:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo sed 's/trusty/saucy/g' -i /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list
sudo apt-get update
sudo apt-get install -y boot-repair && (boot-repair &)

I've runned the Recommended repair, and followed the commands it gave me for terminal, and when it finished and restarted it still booted with Ubuntu only. Than I run Boot Repair again and after the program is done checking the problems, clicked on "Advanced options"-Boot Location tab. Bellow where there is a drop down menu against "OS to boot by default:" there was Ubuntu 14.04 and Windows 7, so I choose Windows 7 and than 'Apply'. When the process has finished I restarted and the GRUB now had the option to let me choose if want to boot with Ubuntu or Windows again. SOLVED

Hope it works for you as well !!!

  • How you added the repository when there is no support for 14.04 ? I mean, the command sudo add-apt-repository ppa:yannubuntu/boot-repair should return errors and add nothing. – NickTux May 4 '14 at 19:18
  • Yes I've noticed the same think but after when I realized it after I've written it here, but I tried it and it truly and surprisingly worked. I'm not that advanced user to conclude why it worked, and in this case I'm glad I wasn't because wouldn't have probably tried it, hahaha. Sorry I wasn't helpful with that answer. – Valentin May 5 '14 at 21:01

Boot Ubuntu or any Linux distro from USB/CD live then open the terminal and tip " sudo fdisk -l " to view all your partitions of all your hard disks

Then you have to identifier Ubuntu partition, then mount your Ubuntu partition selecting the partition where you installed it normally is the sda1, you can check it using the command " fdisk " or using GParted " sudo mount /dev/sda1 /mnt "

Then mount the others devices

sudo mount --bind /dev /mnt/dev

sudo mount --bind /dev/pts /mnt/dev/pts

sudo mount --bind /proc /mnt/proc

sudo mount --bind /sys /mnt/sys

Now run the chroot comand to have full root access " sudo chroot /mnt "

after run " grub-install --recheck /dev/sda " But be sure tu replace sda to the device that you use to boot your system (don't put the partition number only sda)

Finally adjust automatically the GRUB menu tipping sudo update-grub2

If it does not work connect to internet and run this command sudo apt-get install grub2

If you have any question please ask, I always use this step when GRUB does not work properly. I have been translated this instruction from a Spanish document instruction so pleas ask if you have a question

Unfortunately, I experienced this issue after trying to install what appears to have been a corrupted Ubuntu 15.04 -- after install, it landed me in an OpenBox WM with much configuration broken. Additionally, my Windows 7 hard drive (seperate drive) somehow managed to get corrupted in the process.

In the windows CD repair-mode command prompt, issuing "bootrec /fixmbr" followed by "bootrec /fixboot" and then running Startup Repair from the Windows CD allowed me to get into the machine. However, my filesystem had been destroyed -- Steam, drivers, etc all corrupted. I'm amazed I was even able to log in.

Reinstalled. Windows first, then Ubuntu 14.04, no issues this time.

I also encountered this grub error "symbol 'grub_term_highlight_color' not found" after upgrading Xubuntu from 13.10 to 14.04 on a dual partition Windows 8.1/Xubuntu. I've upgraded Xubuntu in the past with no issues, but when upgrading last night from 13.10 to 14.04, I found myself stuck at the grub rescue prompt. Given that I haven't encountered this issue before, I decided to try the Boot Repair utility as is detailed here: https://help.ubuntu.com/community/Boot-Repair. I needed to go with the "2nd option" noted on that help page, because I had no way to create a Boot Repair CD.

Here's what I did exactly:

On my laptop I went to xubuntu dot org where I downloaded the Live Xubuntu ISO. If you have a writeable disc drive, I'm sure you can create a LiveCD with this ISO file (presumably you could create a Boot Repair CD, too), but my laptop has no optical drive.

So, I then created a bootable LiveUSB of Xubuntu 14.04. The instructions I followed to create the LiveUSB can be found here: http://blog.tinned-software.net/create-bootable-usb-stick-from-iso-in-mac-os-x/ (keeping in mind my laptop's Mac OS required the "sudo" command to write to the formatted USB, as detailed in the comments of that post).

With the finished LiveUSB of Xubuntu in hand, I rebooted the grub error computer, changing the boot menu to recognize the LiveUSB, which loaded the Xubuntu Live. I chose "Try Xubuntu" when the LiveUSB asked me to try or install. This loaded a Xubuntu session showing all my partitions as desktop icons.

I opened a terminal and ran the following as detailed in the above-linked Boot Repair help page:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo sed 's/trusty/saucy/g' -i /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list
sudo apt-get update
sudo apt-get install -y boot-repair && (boot-repair &)

I followed the instructions in the Boot Repair utility, which were fairly self-explanatory. Boot Repair recognized my partitions and ran its process, but finished with an "error" Ubuntu Pastebin address. I copied that down, but it seemed that the error was linked to extra drives on the machine that have no OS. Regardless of the error, Boot Repair still gave the option to reboot, so I did.

I obviously made sure my boot menu pointed to the correct drive, and voila! Grub recognized all my partitions again as it was supposed to. I loaded up Xubuntu, and it looks like 14.04 runs just as it should now that the Boot Repair has done its work. Additionally, I can load Windows 8.1 just fine.

Hopefully my notes are of some usefulness. I'm grateful for Boot Repair and for all the dedicated troubleshooters out there!

First boot from live ubuntu cd or Live ubuntu flash drive and connect to internet. After that go to termianl by ctlr+alt+T and just use the command below,

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo sed 's/trusty/saucy/g' -i /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list
sudo apt-get update
sudo apt-get install -y boot-repair && (boot-repair &)

This actually fix any problems I have with boot. You will find a attached link, it has screen short and clear instruction. Have Fun.

Reference link: FOLLOW ME FOR FURTHER CLARIFICATION !

Just two commands at the terminal, and you must be done.

sudo os-prober
sudo update-grub

and just reboot your system now.

  • os-prober merely looks for operating systems. It doesn't change the system configuration in anyway. The only useful command here is update-grub (which is by default configured to call os-prober and use its result), which makes this answer a duplicate. – David Foerster Nov 29 '14 at 17:39

Try to reinstall grub, type in terminal: sudo grub-install /dev/sd_ (where sd_ is the device to install the bootloader to) then sudo grub-update, I hope That will help you Note: sda in /dev/sda can be in device you have grub installed in.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.