enter image description hereI'm having an issue with my nvidia-331 driver. I can't seem to switch between Intel and Nvida via nvidia-settings. The option is there but when I click 'nvidia' a blank error window pops up. It's very weird because I've been using the Ubuntu daily for a while on 14.04, and it was not until yesterday's update that I've had this issue. Same driver. Does anyone know how to fix this? Thanks. I've tried a clean install and have the same issue.

  • The same issue I also have. Even when I have my external monitor connected the mouse pointer flickering. From my point of view Ubuntu 14.04 Alpha and Beta was more stable than the final release. Strange!
    – vasiauvi
    Apr 19, 2014 at 10:52
  • did you try sudo prime-switch nvidia?
    – Aurelia
    Apr 20, 2014 at 12:36
  • I resolved the issue by re-installing Ubuntu. Thanks for the suggestion though. @vasiauvi
    – Brandex
    Apr 21, 2014 at 20:49
  • Same issue here as well, still no way found to fix it. By the way, from the time that nvidia-prime has stopped working, Bumblebee has started to work (while when nvidia-prime worked, bumblebee was not).
    – user273314
    Apr 23, 2014 at 21:43
  • Mlacunza solution worked perfect! I did second part only, from purge line. The only thing I have to reboot to switch correctly, log off don't work well. Thanks!
    – user315581
    Aug 14, 2014 at 9:12

5 Answers 5


I also had the same problem but only after I made some modification on compiz.

For the fix, I just reinstalled the nvidia drivers and nvidia prime with

sudo apt-get purge libvdpau-va-gl1 bumblebee* nvidia*
sudo apt-get install nvidia-331 nvidia-settings nvidia-prime
  • Perfect! Just the package has been renamed i guess. Had to change it to sudo apt-get install nvidia-driver-455 nvidia-settings nvidia-prime Sep 24, 2021 at 12:49

If you encounter the problem with prime like an empty popup error in nvidia-settings panel you can see the bug in Launch Pad 1310023. I have encounter a similar problem and I can correct them with that:

sudo update-alternatives --config x86_64-linux-gnu_gl_conf
sudo ldconfig -n
sudo update-initramfs -u

then reboot and see if it works

  • 1
    This solved my problem. I have Alienware + Ubuntu 14.04, 1 Monitor on HDMI + 1 Monitor on mini DP.
    – Manatax
    Jul 23, 2014 at 22:18
  • 1
    Solved my problem with a GeForce 610M.
    – Steve K
    Aug 25, 2014 at 9:28
  • 1
    This works, but once I reboot again the fix is lost and I have to re-input the commands and, yet again, reboot. Do you know of a way of making the fix permanent?
    – Fern Moss
    Oct 11, 2014 at 23:05
  • @AibaraIduas the fix return error or warning during the installation ?
    – olituks
    Oct 12, 2014 at 8:05
  • No, no error. And it works fine at first, until I reboot it again. Weird.
    – Fern Moss
    Oct 12, 2014 at 20:46

Here, this is what worked for me:

I tried:

sudo update-alternatives --config x86_64-linux-gnu_gl_conf
sudo ldconfig -n
sudo update-initramfs -u

And rebooted, with no changes. So I tried:

sudo apt-get purge libvdpau-va-gl1 bumblebee* nvidia*
sudo apt-get install linux-headers-generic
sudo apt-get install nvidia-331 nvidia-settings nvidia-prime

Reboot. Still, no changes, and the same blank error message in nvidia-settings when I try to switch to me nvidia card.

I tried switching manually, using sudo prime-switch nvidia, and configuration info was updated. I tried again, and nvidia-settings asked me to log out and log back in and...voilà! I've got it working!

In my case, it appeared that before being able to switch using nvidia-settings UI, I had to manually switch first as superuser, so as to generate the proper configuration!

Good thing I tried that, or I'd still be tinkering about, installing other drivers! Hope this proves useful to someone else!


For me I actually just went into my bios changed it to use discrete only, boot back into ubuntu, and then made sure nvidia x server was running properly, rebooted again and changed it back to optimus and it fixed the error.

  • This isn't an option in the bios of my UX32VD but that makes sense for other laptops. Thanks though.
    – Brandex
    Apr 26, 2014 at 19:43

Im using Lenovo Ideapad S410p with Nvidia GT 720M with Ubuntu 14.04 64bits after the same problem and expend many days trying to fix all and I try all since xorg-edgers install nvidia drivers and a lot of etc...., I can fix the problem making a new clean installation, so for me some config files, installations and residual info was wrong with my previous trys to fix.

Now Nvidia settings works too and dont show me the bug reported here and in launchpad (Bug 1310023) If someone have the same dont forget report it too in Launchpad.

Hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .