4

I edited the xconf file, and added this line to device section:

Enable brightness control=1

Now I am able to adjust brightness, but after every restart the brightness setting change back to 100%.

Is there any solution for this?

8

To adjust brightness in xubuntu or ubuntu Open a terminal window, and execute this command to edit /etc/rc.local:

sudo nano /etc/rc.local

Add this before the last line “exit 0″:

echo xx > /sys/class/backlight/acpi_video0/brightness

Where number xx is the value of your screen brightness of your choice.

The maximum value for brightness can be found with:

cat /sys/class/backlight/acpi_video0/max_brightness
  • for others newbie(like me): use ctrl+insert to paste the text from clipboard in nano – Arash Aug 8 '14 at 15:14
  • How do you save it afterwards and exit? – Valentin Aug 9 '14 at 17:47
  • 1
    Laptop with Intel card, path is: $ cat /sys/class/backlight/intel_backlight/brightness – Daniel Jun 13 '15 at 17:44
3

Fix brightness control issue with Intel card in Ubuntu:(check which card is there:settings/details/graphics)

Open a terminal and create the following configuration file, if it does not exist:

touch /usr/share/X11/xorg.conf.d/20-intel.conf

Now we need to edit this file. You can use any editor be it a terminal one or graphical.

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

Add the following lines to this file:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"

EndSection

Save it. Log out and log in back. The brightness control should be working through function keys now:

  • 1
    This made my display driver to crash on 14.04 – Shervin Asgari Jul 23 '14 at 21:53
  • Mine too! this does not work and I wasn't able to get my ubuntu up and running after a reboot. Had to re-install. – Darth Coder Sep 4 '14 at 5:59
  • Worked for me with Ubuntu 15.04. – Indika K Jul 28 '15 at 9:56
2

create a file in /usr/share/X11/xorg.conf.d/80-backlight.conf and include following in the file.

Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "AccelMethod" "sna"
    Option "Backlight" "intel_backlight" # use your backlight that works here
    BusID "PCI:0:2:0"
EndSection
2

In /etc/default/grub make sure you have acpi_backlight=vendor in GRUB_CMDLINE_LINUX_DEFAULT.

Here is mine:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Then run update-grub and reboot.

Fixed it for me, HP ProBook w/ Intel Grpahics card, fresh 14.04 Desktop install.

  • Thx mate. I tried what not. works like charm. Do not forget to reboot – HIRA THAKUR Nov 2 '15 at 5:49
2

Type this command in Terminal:

xrandr --output LVDS-0 --brightness 0.5

0.5 is used to decreased to adjust screen Brighness.

Should work Perfectly.

if not

xrandr --output LVDS1 --brightness 0.5

will do the job

0

If you want to change the screen brightness in Ubuntu

(I can’t change it using the keyboard shortcuts or the Ubuntu Power Management menu),

open a terminal and execute the following:

sudo setpci -s 00:02.0 F4.B=xx

Where xx is the desired brightness in hex ranging from 0 (brightest) to FF (no brightness at all). I usually change it to E0 when working on battery.

Not the answer you're looking for? Browse other questions tagged or ask your own question.