So I decided to upgrade to 14.04 from 12.04 on my Wubi installation, using update-manager -d, but I can no longer boot into Ubuntu. When I try to, I see the message mount:mounting..."etc, then "Target filesystem doesn't have requested /sbin/init". Does anyone know how to solve this?

mount: mounting /dev/loop0 on /root failed: Invalid argument
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target filesystem doesn't have requested /sbin/init.
No init found. Try passing init= bootarg.
  • If you want to use wubi installer for Ubuntu 14.04 you should download and install Lubuntu 14.04 with the wubi installer included inside the iso image. After you finish with installing the system you can add Canonical Partners and Independent repos to the software sources list, and then you can install ubuntu-desktop, unity and anything else you need to run Ubuntu. I tested this before April 17th, and I was able to install Lubuntu 13.10 with wubi. I suppose wubi installer will install Lubuntu 14.04 after april 17th.
    – Taz D.
    Apr 18, 2014 at 22:30
  • askubuntu.com/questions/453651/…
    – bain
    Aug 6, 2014 at 0:11
  • 1
    possible duplicate of Windows installer for Ubuntu 14.04 LTS onwards
    – bain
    Aug 6, 2014 at 0:14
  • @bain the answers on that question do not address the problem in this case, which is an "unusable" Wubi installed Ubuntu after an upgrade.
    – Alaa Ali
    Aug 6, 2014 at 16:09
  • @AlaaAli Yes, the point was supposed to be that Wubi installs are not really supported for 14.04. I have seen several reports of people upgrading Wubi installs to 14.04 to find numerous things broken, and also "Seriously, wubi is not recommended for anything newer than 12.04 LTS, and I'm glad it worked for you up to 13.10, but it's unlikely to work at all now with the recent changes in Ubuntu. The terminal bootup commands instructions aren't working because the kernel can't find your root partition, because it's installed the wubi way, which isn't supported anymore."
    – bain
    Aug 6, 2014 at 16:48

2 Answers 2


From https://answers.launchpad.net/ubuntu/+question/247265

Steven, I've found a solution that works, that is, if you haven't tried to reinstall yet:

If you can find your boot commands, find the line that says:

linux /boot/vmlinuz-3.13.0-24-generic root=UUID=D014E45... etc...

Change "ro rootflags= sync" to "rw rootflags=sync"

That's it. Just that one character. Nothing else. Worked for me, hopefully it does the same for you. Here's hoping.


Daniel - thanks for posting that solution, my dad's laptop was suffering from this, and I managed to get a remote session on it and repair it for him thanks to your post. He's very pleased :)

For what it's worth, I also updated the grub regeneration files in /etc/grub.d/10_linux to ensure that it remains set to "rw" after a kernel update. Just replace this line:

    linux ${rel_dirname}/${basename} root=${linux_root_device_thisversion} ro ${args}


    linux ${rel_dirname}/${basename} root=${linux_root_device_thisversion} rw ${args}

In summary, to recover, I did (from memory):

  • boot from xubuntu cd (Try ubuntu without installing)

  • open terminal, locate root volume on the windows drive, mount it with:

sudo -i

mkdir /mnt/recovery

mount -o loop /media/xubuntu/Data/ubuntu/disks/root.disk /mnt/recovery

apt-get install vim

vim /mnt/recovery/boot/grub/grub.cfg  # set "ro" flags to "rw" as per Daniel's comment (#8 above)

vim /mnt/recovery/etc/grub.d/10_linux  # change "ro" to "rw" as above


During Grub, press "e", that will bring up the editor, locate to where it says ro and change it to rw.

You have to do this everytime you boot.

To make the change permanent, run gksu gedit /etc/grub.d/10_lupin after booting (replace gedit with your favourite editor, use sudo nano /etc/grub.d/10_lupin if you are in the tty), locate the line which says

linux   ${rel_dirname}/${basename} root=${LINUX_HOST_DEVICE} loop=${loop_file_relative} ro ${args}

and change the ro to rw, like this:

linux   ${rel_dirname}/${basename} root=${LINUX_HOST_DEVICE} loop=${loop_file_relative} rw ${args}

Save the file, and run sudo update-grub.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.