1

Just after upgrading my Xubuntu 13.10 to Xubuntu 14.04, I run the command: sudo apt-get dist-upgrade and tell me that upgrade are available, and after do it again and again I get the same result after installing thus packages. Note: all packages are really installed, is like to reinstall them every time

  • The steps to properly update (via command-line) are: sudo apt-get update && sudo apt-get upgrade, followed by sudo apt-get dist-upgrade. Try that, and report if there is still an issue. – david6 Apr 18 '14 at 21:33
  • @david6 you can skip dist-upgrade if you do not have held packages with update. You can skip update if you are going to later run dist-upgrade. The commands sudo apt-get upgrade and sudo apt-get dist-upgrade usually do not both need to run. In addition, the OP is asking about upgrading not updating. – Panther Apr 18 '14 at 21:36
  • Don't necessarily agree. Skipping sudo apt-get update can confuse things, and he may be being confused by MOTD reminders for updates available. – david6 Apr 18 '14 at 22:14
  • How to fix that please? – karim Apr 18 '14 at 22:23
2

dist-upgrade does NOT upgrade the system.

From the apt-get man page:

dist-upgrade

In addition to performing the function of upgrade, this option also intelligently handles changing dependencies with new versions of packages; apt-get has a "smart" conflict resolution system, and it will attempt to upgrade the most important packages at the expense of less important ones, if necessary.

To upgrade , run sudo updater

Or to do so graphically, see http://www.ubuntu.com/download/desktop/upgrade and https://help.ubuntu.com/community/UpgradeNotes

|improve this answer|||||
  • No I upgraded it be the command 'sudo update-manager -d', and atfer everything is done successful after rebooting I used 'sudo apt-get dist-upgrade' and I have that issues – karim Apr 18 '14 at 21:34
  • The -d option is not necessary, and in fact should not be used. From the man page " -d, --devel-release Check if upgrading to the latest devel release is possible". You do not want to upgrade to the dev release ;) At any rate, post your commands and error messages. – Panther Apr 18 '14 at 21:38
  • this is result of 'lsb-release -a': 'No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04 LTS Release: 14.04 Codename: trusty ' – karim Apr 18 '14 at 21:56
  • it appears the upgrade went well. What problem are you having ? – Panther Apr 18 '14 at 21:59
  • When I run 'sudo apt-get dist-upgrade' or 'sudo apt-get upgrade' I have 969 packages to by updated I thus packages are really updated, this is the problem – karim Apr 18 '14 at 22:03
0

The problem is that I've made a partial upgrade so I got some Ubuntu 14.04 packages but not all, when I've finish All upgrades that remained I no longer have any issues now. Thank you guys for your help.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.