1

I made and ran a shell script made up of the following:

wget -q "http://deb.playonlinux.com/public.gpg" -O- | sudo apt-key add -
sudo wget http://deb.playonlinux.com/playonlinux_precise.list -O /etc/apt  /sources.list.d/playonlinux.list
sudo apt-get update
sudo apt-get install playonlinux

However, the installation failed. Since then I cant run any of Update Manager, Software Center, Synaptic Package Manager, they all segfault. None of the apt-get commands return any error messages nor do anything else.

Should I try and delete: /etc/apt/sources.list.d/playonlinux.list directory? It still has playonlinux.list.save, playonlinux.list files in it. Something must be corrupted, just dont know what since I get no specific error messages via bash.

Would appreciate any help, really don't want to reinstall.


Okay so after:

sudo apt-get upgrade -o APT::Cache-Start=100000000

I can run software-center again it doesn't crash

laarson@laarson-EP31-DS3L:~$ sudo apt-get upgrade -o APT::Cache-Start=100000000 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be upgraded:
  gimp-gmic whoopsie
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,893 kB of archives.
After this operation, 6,144 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu/ precise/main gimp-gmic i386 1:1.5.8.6.1-0precise0~ppa [1,867 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ precise-updates/main whoopsie i386 0.1.34 [26.2 kB]
Fetched 1,893 kB in 2s (712 kB/s)                                                     
(Reading database ... 633686 files and directories currently installed.)
Preparing to replace whoopsie 0.1.33 (using .../whoopsie_0.1.34_i386.deb) ...
whoopsie stop/waiting
Unpacking replacement whoopsie ...
Preparing to replace gimp-gmic 1:1.5.8.6-0precise0~ppa (using .../gimp-gmic_1%3a1.5.8.6.1-0precise0~ppa_i386.deb) ...
Unpacking replacement gimp-gmic ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Setting up whoopsie (0.1.34) ...
whoopsie start/running, process 4358
Setting up gimp-gmic (1:1.5.8.6.1-0precise0~ppa) ...

update-manager does run aswell

I still get some weirdness as update-manager did crash again. The update manager does crash when trying to get info from network.

So when ever i run update or upgrade in bash with -o APT::Cache-Start=100000000 it seems it makes segfault gone.

Without it sudo apt-get update does give the errors again. what is going on?

http://ubuntuforums.org/showthread.php?t=2209984

0

/etc/apt/sources.list.d/playonlinux.list shouldn't be a directory; it should be a file.

Start by deleting that directory/file. Then, correct the second line of your script; it should be sudo wget http://deb.playonlinux.com/playonlinux_precise.list -O /etc/apt/sources.list.d/playonlinux.list (no space in-between).

On another note, if you aren't doing a batch install or something, you could just add it through Software Sources and get rid of some of the risk.

  • thank you for you answer. After some more research i do get: laarson-EP31-DS3L kernel: [ 175.082173] apt-check[2778]: segfault at b5d2ccb4 ip 007a6b51 sp bfb64740 error 6 in libapt-pkg.so.4.12.0[6d1000+124000] laarson-EP31-DS3L kernel: [ 176.359893] aptd[2812]: segfault at b5de5cb4 ip 06934b51 sp bf97f060 error 6 in libapt-pkg.so.4.12.0[685f000+124000] kernel: [ 324.316111] apt-get[3229]: segfault at b5f22cb4 ip 00aa0b51 sp bfbcac00 error 6 in libapt-pkg.so.4.12.0[9cb000+124000] – Laars Apr 19 '14 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.