3

I am running Ubuntu Desktop 14.04 with Unity. It has some great keyboard combos for navigating about my various windows. Super + W shows all open windows. Alt + Tab lets me scroll through applications. Alt + ` lets me scroll through just the windows for a given application. It's a great tool set when you have too many windows and not enough screen real estate. However, what I'd really like is something like Super + W that excludes minimized windows. Don't get me wrong, seeing the minimized windows is great sometimes, but sometimes they create screen clutter.

I have some applications that I'd really like to just minimize to the tray (I know that's a Windows concept that I'm not sure translates entirely to Ubuntu, but bear with me) because I'm not actively using them. I only have them running to get notifications (Geary email client, Skype, etc.), but they don't support sending to the tray, so I have them minimized. That's more or less okay, but then I have 4 extra windows cluttering my screen when I Super + W.

Anyone know a way to exclude these from Super + W? Or make applications go to the tray and keep running when you close their window?

3

I solved this by editing the window matching field in the CompizConfig Settings Manager. I don't think it's installed by default, but it's easy to find in Software Center. Once you have the Settings Manager, go to:

Window Management > Scale > Behaviour > Scale Windows

This field accepts a string that conforms to Compiz's WindowMatching syntax. You can edit it to declare which windows should be included when the Scale plugin activates. Here's the string I used to exclude minimized windows:

(Toolbar | Utility | Dialog | Normal | Unknown) & !state=hidden

  • That seems like more effort than should be required, but that's not your fault. It's a valid solution, the only one suggested, and highlights an intriguing power feature I'll have to look into next time I'm running an Ubuntu desktop. – eimajenthat Jan 26 '16 at 1:53
0

Another option that seems to work for me, for the record, is to open Unity Tweak Tools (in the repository if you don't already have it) and go to the settings for the switcher, where there's an option to enable or disable switching between minimized windows. Unchecking that box appears to also affect the window spread.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.