I have tried all afternoon to fix this, but now I give up. I am trying to set up an old XP PC with Lubuntu 14.04. It works perfectly fine, except for the wireless connection. Connecting with ethernet works fine.

I have a D-Link DWL-G122, trying to connect to a Fritz!Box 7170 with WPA (TKIP) - I switched from WPA + WPA2, but no effect.

I have tried with wicd, where it hangs at trying to optain an ip address from the dhcp server. i tried a static IP, it did connect to the wifi, but I had no internet connection then. Also, I didn't like the hack, since it's my parents PC, where I'd like to have everything set up properly for when I am not around.

I removed wicd, and with the network-manager service stopped, i tried it with terminal and sudo dhclient -v wlan0 but I still could not get an ip address. I tried with the network-manager (removed and reinstalled), but I just can't get it to connect.

When I click the icon in the tray, the connection properties pop up and in the connection is only listed lo and eth0. My /etc/network/interfaces looks like this:

interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
auto wlan0
iface wlan0 inet dhcp
#auto eth0
#iface eth0 inet dhcp
#auto ath0
#iface ath0 inet dhcp

if you need any output of anything, I will do that.

How do I make the connection?


The outcome of the wireless_script (as suggested) can be found here http://pastebin.ubuntu.com/7281731/

The lines

ieee80211 phy0: rt2x00lib_autowakeup: Error - Device failed to wakeup
ieee80211 phy0: rt2500usb_set_device_state: Error - Device failed to enter state 3 (-16)

can be found repeating. So I googled the first one and found that proposal:

sudo /etc/init.d/network-manager stop
sudo iwconfig wlan0 power off
sudo service network-manager restart

And it works, right after the second line. I do have to click the tray icon and select wlan0, but then it works.

However I have to do that every time after I login. And it takes now 2 minutes more to boot, because lubuntu tries to configure the network.

up vote 3 down vote accepted

Several things need to be done.

Remove wicd completely and make sure you only have network manager installed and running you can check with this command:

    ps aux | egrep 'Network|wicd'

Turn power management off:

    sudo gedit /etc/pm/power.d/wireless

(this will create or edit a configuration file that will override the default power management behavior) and enter the following:

#!/bin/sh

/sbin/iwconfig wlan0 power off 

then save gedit and close.

Remove all spaces and special characters from your network name.

Run the following command:

    sudo gedit /etc/network/interfaces

and remove everything in that file but:

auto lo
iface lo inet loopback

save and close.

Set encryption in your router to wpa2 AES (CCMP) not TKIP. You will need to be hard wired to your router and 192.168.0.1 typed into your browser usually gets into the router configuration page if it does not you may have to look at the documentation for your router to get the exact numbers you need to type.

Set network manger settings to match the screenshots. network manager settings network manager settings now reboot and if it does not connect post back a new wireless file so we can make sure the changes stayed.

Edit: Second method to turn power management off:

echo -e '#!/bin/bash\n/sbin/iwconfig wlan0 power off' | sudo tee -a /etc/pm/power.d/wireless
sudo chmod +x /etc/pm/power.d/wireless    
  • You are cool Wildman , – rɑːdʒɑ May 13 '14 at 8:00

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.