I have: ASUS P4V800D-X Intel Pentium 4 HT 2.80GHz 2.5GB RAM 40GB HDD nVidia 9500GT

When I installed nVidia drivers downloaded from nvidia.com website (selected recommended drivers), I simply can't boot into desktop. I pass through purple screen, and then I get black screen with flashing white underscore on left hand side. Keyboard shortcuts are not working and the only way to get to desktop mode is booting into recovery mode (holding shift when booting etc.). In recovery mode I run:

sudo apt-get remove --purge nvidia*

and that is the only way to get a "normal" desktop environment. I put a quotes on a normal because computer is running slow and I can't set proper resolution.

Also, I've tried to install drivers via ubuntu GUI interface (proprietary, tested drivers), but with no luck.

I am using Ubuntu 14.04

  • Install the package apt://nvidia-current (sudo apt-get install nvidia-current, if apturl doesn't work)
    – s3lph
    Apr 18, 2014 at 21:59
  • Thanks for the answer, but I still have the same problem.
    – Dobroslav
    Apr 19, 2014 at 9:28

6 Answers 6


I've finally solved my problem! For people who have the same problem like I had, here is the solution:

I recommend to make a fresh install of your system, if you already have an issue with drivers.

  1. Boot up Ubuntu and make sure you're connected on the internet.
  2. Open a terminal with Ctrl + Alt + F1
  3. Login and here is what you have to type in terminal:

    sudo apt-get update
    sudo apt-get dist-upgrade
    sudo apt-get install build-essential
    sudo apt-get install linux-source
    sudo apt-get install linux-headers-generic
    sudo apt-get dist-upgrade
    sudo reboot
  4. After reboot, repeat step 2. You'll need here an internet connection, again. Run these commands:

    sudo apt-get install nvidia-current-updates
    sudo nvidia-xconfig
    sudo reboot

It is very important to run nvidia-xconfig! If you don't run it, you'll crash your system!

After you've done this, you'll have a working nVidia graphics driver. Cheers!

  • This doesn't work for me... I'll post my own answer. Oct 30, 2014 at 6:48
  • 1
    Hi. Can I ask you to explain something for me so I understand the reason of "why" these commands fix the issue. What does the build-essential, linux-source, and linux-headers-generic commands do? And how on earth did you figure out HOW to do that? It's not like a new person to Ubuntu (me) could just think, AH! I know what i'm missing and just guess those commands. I really want to understand what this config is doing, and how you figured out to use it.
    – john smith
    Jun 14, 2015 at 18:25
  • For me ctrl + alt + f1 doesn't do anything. I am still stuck at the black screen with blinking cursor.
    – docpkd
    Aug 16, 2016 at 1:32
  • This didn't work on my MacBook Pro 2010 (NVIDIA 320M) on Xubuntu 18.04. I still get the black screen and booting with shift pressed doesn't show the menu. Oct 10, 2018 at 15:10

I'm on a HP 8710p and upgraded to the nVidia drivers a while ago. Now I run into black screens during boot, seemingly randomly.

Dobroslav's accepted answer - reinstalling the nVidia drivers and recompiling the kernel - seemed to solve the problem at first, but later I ran into a black screen again.

I searched around and found that this theory might explain the problem. Because twice in a row, things seemed to work directly after installing the new nVidia driver, but after the next reboot the black screen was back. Then on the next reboot, all was fine again. This would match with the theory that on reboot, the kernel module gets recompiled, but X already gets started before that happens, and so the module is not loaded - but on the next reboot it will already be compiled, and things work as normal.

So I found a workaround to the problem: whenever I get the black screen, I get rid of it by restarting X using these steps:

  1. Open a terminal with Ctrl + Alt + F1
  2. Login and type in terminal:

    ps a | grep X
  3. One of the lines will contain '/usr/bin/X' and start with a number, then 'tty7'. Eg. '2261 tty7'. Remember the number, which is the process id of the X server, and type:

    kill <number>

In my case, I then see an nVidia screen and directly after that I see the X login prompt come up. It's not a solution, but it's an acceptable workaround for me for now - at least I don't have to reboot or work with outdated drivers. I hope it helps someone else.


I fumbled around with Nvidia drivers and this black screen issue for two days. And I fell into this pit because of the 14.04 upgrade from 12.04. Grrr!

The original issue I was trying to resolve was the high cpu utilization of firefox, compiz & Xorg which made the graphics fairly unusable. After attempting to resolve that issue by upgrading the Nvidia driver, all went south and the black screen of death ensued.

Here's some commands that speak to my desktop configuration in case that helps...

"lshw" command produces:

description: Mini Tower Computer
product: OptiPlex GX270

"lspci -vnn | grep -i VGA -A 12" command produces:

VGA compatible controller [0300]: NVIDIA Corporation NV18 [GeForce4 MX 440 AGP 8x]

"wmctrl -m" command produces:

Name: Metacity
Class: N/A
Window manager's "showing the desktop" mode: N/A

At the end of the day, I'm not 100% sure what worked as I fumbled around so much. Here's what I think did it.

Use the following to get rid of all Nvidia bits and rely on the default driver Nouveau.

sudo apt-get purge "nvidia *"

Then opt for using Metacity instead of Compiz. Those are the two salient changes I made and the result is a much improved graphics experience with acceptable cpu utilization when doing something such as video streaming from CNNx. Firefox still shows high cpu utilization in "nice top" but that doesn't seem to impact the graphics and especially the video streaming.

  • @amc This seems like an answer. See the text after "Here's what I think did it." Oct 17, 2014 at 2:37
  • @EliahKagan fair enough, though there's a lot of extra info, and it's not a "confident" answer.
    – amc
    Oct 17, 2014 at 2:52

Had the same issue and this is what worked for me:

  1. install synaptic sudo apt-get install synaptic

  2. within synaptic, find the latest Nvidia driver by typing "nvidia" then search and checking version number (in my case v331.38) nvidia-331-updates

  3. after synaptic has done its thing, in a terminal: sudo nvidia-xconfig

Now I get a perfect boot and am using driver v331.38, not the latest but the latest certified by canonical.


The following thing worked for me.

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install build-essential
sudo apt-get install linux-source
sudo apt-get install linux-headers-generic
sudo apt-get dist-upgrade
sudo apt-get install nvidia-current-updates
sudo nvidia-xconfig
sudo reboot

After trying many solutions and recommendations, I still was not able to resolve the black screen on boot issue. I will say though, 14.10 in-place upgrade resolves the problem. I have not done any more investigation, but this might mean that possibly updating the kernel version may fix it if you stay on 14.04. (?)

I am currently on an Asus N53SN laptop with and Nvidia 550m card.

Not the answer you're looking for? Browse other questions tagged or ask your own question.