I have a 15-inch 2.53ghz mid-2009 macbook pro (in some places known as "macbookpro 5.4"). I wanted to dual boot mac os x with ubuntu 14.04 desktop 64-bit, so I set up a secondary partition using disk utility (not bootcamp assistant as it wants a windows 7 disk). I rebooted, booted from the ubuntu dvd I burned (there are two options in the boot menu, the EFI version called "EFI boot" and the BIOS version misleadingly called "windows," I chose the EFI one), and first thing I do is check disk for defects, and there aren't any. So I reboot and start up the installer, but the Ubuntu splash screen comes up garbled and it stays there forever. (I've waited 2 hours, I don't think the live cd is supposed to take that long to start). So I noticed there was something wrong.

One potential solution I found was installing refit on the mac os x partition. So I did. I started up the efi boot loader from the Ubuntu disk using refit instead of holding down option on startup (needed to refresh a couple times for refit to see the dvd), same result. Another solution was booting with nomodeset. This time it didn't get stuck at the splash screen, but a completely black screen (no blinking cursor either) after being at the boot screen for a while. It could be a video driver problem, but how, if I've booted with nomodeset?

I've also tried the "64-bit mac" version that they offer on the download page. That version doesn't have an efi version, only bios, but it boots exactly the same way (either stuck on the boot screen or a black screen).

I don't want to try the 32-bit version as it could be much slower and also won't recognize my full 8gb of ram. (edit: tried it, still boots to a black screen)

4/23 update: After commenting the answers I got, I should mention that on my macbook pro I have downgraded the efi firmware from 1.7 to 1.6 because I replaced the hard drive myself (the original one died), and the 1.7 update makes hard drives you replaced yourself become so slow they're unusable because they're "unsupported". For this reason I also can't install anything newer than mac os x mountain lion 10.8.3 on my mac, even if it would work normally (it would throw looping errors similar to the ones I mentioned in a comment), in fact I'm stuck on lion 10.7.5. The solution I found on the internet about this only works for seagate hard drives, and I have a western digital.

If I upgrade the efi firmware again, I could finally install Ubuntu, but it would be slowed down to a crawl (random hangs every 10 seconds or so), so it's not worth it. I'd rather just buy a new $300 non-apple laptop and put Ubuntu there. Thanks everyone who answered, but I'm open to trying something else to get it to work, if anyone has a potential solution.

2017 update: I bought a newer computer, but I kept this older macbook as a secondary one. To make it faster, I replaced the hard drive again, this time to a SanDisk SSD plus, and despite it still being unsupported by Apple, it works perfectly with the old 1.6 EFI firmware. Not only does Ubuntu work fine, but so do newer Mac OS versions (up to 10.11 El Capitan officially, even 10.12 Sierra if you use dosdude1's patch). The old Apple EFI firmware caps the SATA speed at 1.5 Gbit/s, but with a solid state drive this computer works very quickly, so I won't attempt updating it.

  • Same here... Ubuntu 14.04 is the first linux distro where this has happened. – – king_julien May 18 '14 at 15:04
  • It also happens for me on 12.04. Not on 10.04 though. – dick Jun 14 '14 at 13:23
  • Did you get wifi working? – William Mar 9 '17 at 20:17
  • @LiamWilliam Yes. You have to connect to the Internet with Ethernet, and then use the "Additional Drivers" thing in Ubuntu to download and install the wi-fi drivers. – dick Mar 10 '17 at 7:16

Have you tried replacing or pulling/pushing/checking the HDD cable? It's a common failure in macbooks from around 2009. I've had 3 macbooks with this failure in my company (and there is not so much macbook there...) The problem is exactly the same as you describe. Computer way sloooow, and some hangs. Ata errors also, due to timeouts in bus.

The easiest way to make sure if this is the problem is putting your internal HDD in an USB enclosure and boot. If computer is faster through USB (reasonabily faster) than through ATA, you found it. You have then to replace your internal ATA cable (try cleaning and reconecting first). ebay could be your friend here as it's not very cheap...

About your problems due to WD disk instead of Seagate... I've never had any problem replacing macbook disks with any particular brand. In fact I'm used to buy WD and hitachi because they seemed to me that they last for long (But I've used samsung, toshiba...)

  • The cable is plugged in fine. The computer is slow and hangs IF I update the EFI firmware. If I update it, Ubuntu would also detect my HD correctly and install without errors. But because I can't use my computer like that, I have the old EFI, and the computer runs okay, but nothing >Mac OS X 10.8.2 and Ubuntu 12.04 runs. I don't really want to go through the trouble of getting a new SATA cable. External USB drives with mac os x >10.8.2 do work, as it's only a SATA issue. The workaround only works on seagate HDs because the required jumper is missing on WD hard drives. – dick Jun 14 '14 at 13:20

I recommend adding Refit as it suggested. I have never found a workaround to using refit when dualbooting a macintosh computer. Install refit on your computer and restart the installation process.

I recommend inserting the disk and then shutting down. Upon booting hold the option key and you should be able to select the ubuntu disk image. Install as usual but make sure to do the proper partitioning. I can link you if necessary to the instructions for partitions (it has been a while since i used a mac).

Let me know where that gets you (sorry I don't have the reputation to only commment, so I will try to guide you through the process)

  • I don't need help on partitions, thanks. I set up a 45gb fat32 partition with disk utility and when I'm installing with ubuntu I'm going to use the "something else" option, delete that partition and use 1gb of the free space as swap area, and the rest as the / mount point. I've actually been using a fork of refit called refind, found at rodsbooks.com/refind. I tried booting the ubuntu cd with that installed, but it didn't work (it boots, but it has the problems mentioned above). Should I uninstall it and try the real refit? – dick Apr 19 '14 at 1:36
  • The original rEFIt is unlikely to do any better than rEFInd; the problem is almost certainly in driver support for your hardware, or in how Apple's EFI is initializing that hardware. – Rod Smith Apr 19 '14 at 16:35

Unfortunately, Apple seems to delight in making changes to particular Mac models that require completely changing everything one needs to do to install anything but OS X on the computer. Chances are it's such model-specific issues that are causing you problems. You might have some luck with a Web search on "Ubuntu" and some variant of your model number. When I did this, I found these instructions -- but they apply to Ubuntu 10.04, so they may not be relevant for 14.04.

Your symptoms are also quite similar to ones reported on many recent PCs. There's a huge question/answer set on this site devoted to this problem, so it's worth checking that out.

In some cases, it's necessary to install in BIOS mode to work around this type of problem, but I'd try sticking with an EFI-mode installation initially. This will enable you to avoid using the flaky and dangerous hybrid MBR that's required for a BIOS-mode boot on a Mac.

  • I decided to try ubuntu 12.04 instead of 14.04, thinking I could at least upgrade to 14.04 later. Unfortunately that does the exact same thing (black screen). So I tried the ubuntu 12.04 alternate install cd, and I finally got it to install, but when I pressed esc at the boot screen for verbose mode it kept looping with some messages like ata1: serror: { PHYRdyChg CommWake DevExch } and some other lines with random words, numbers and characters. Ubuntu 10.04 on the other hand installs and works perfectly. But that's too old. I'm about to give up and just keep mac os x on this thing. – dick Apr 21 '14 at 17:18
  • @dick That error looks like bug #1318218 - SATA problems on MacBook Pro 11,1 The suggested workaround is use powertop and enable "Enable SATA link power Management for host1" (also see bug #539467) – bain Jun 13 '14 at 17:12
  • The thing is, I can't even get ubuntu to install. I get the "ata 1 serror"s when using a live usb drive. However I could see if that powertop thing works both on the live usb and after installing (even if my macbook is model 5.4, not 11.1), if I get it to recognize my hard drive without hanging. – dick Jun 14 '14 at 13:23

I was able to get 14.04 LTR installed on my Macbook Pro 5,3 last night. A few days ago I installed 12.04.4 LTR (64-bit Mac (AMD64) desktop CD) because I knew it would be fully supported. I did it from a USB drive using this method. In my case I didn't have an OSX installation so I booted an OSX Lion install disk and used the terminal there to convert and copy the Ubuntu installation to the USB drive as described in that guide. After having everything up and running I seen this guide on upgrading to 14.04 and decided to give it a whirl and to my surprise it actually worked. Hope this might help you in some way.

  • That's what I tried too, but it hangs when it tries to access my hard drive, read this comment. – dick Jun 14 '14 at 13:25
  • Did you get wifi working? – William Mar 9 '17 at 20:17

Look for the usb repair tool from osx, can't remember the exactly, but you should find it. Erase the disk, and then install mavericks from appstore. (download).

That way i got mavericks on my 2009 whitemacbook 5,2.

Maybe from the repair tool (disk repair?) you can make new partitions easier, and make one for ubuntu. Perhaps bios is the right version to boot? not sure

  • There's nothing wrong with my hard drive. I've checked it with disk utility and fully erased the disk and tried everything, but nothing newer than mac os x 10.8.3 would work properly. This is the problem I have, but I can't do the suggested workaround because my hard drive is not a seagate. https://discussions.apple.com/thread/4921455 – dick May 4 '14 at 11:06

I got the Ubuntu 14.04 installed on my Macbook Pro Mid 2009 (13").

What I did:

  • Installed a rEFInd (http://www.rodsbooks.com/refind/using.html);
  • Downloaded a Ubuntu 14.04 ISO (Normal 64bits ISO, not the +mac) and did a bootable usb drive;
  • Boot up the Mac, selected the usb (at the rEFInd screen), and started the installation.

I think the problem is in the ISO with +mac.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.