enter image description here

In order to work properly, Unity Tweak Tool recommends you install the necessary packages

  • I have uploaded a screenshot of the problem. Please check it out. Commented Apr 18, 2014 at 17:35
  • 17
    -1 to whoever wrote that error message. Yuck. (if they only added a filename one could try apt-file search).
    – Rmano
    Commented Apr 18, 2014 at 18:29
  • @Rmano they did, I found it just fine using apt-file search. the full filename is com.canonical.unity.webapps.gschema.xml; maybe you need to run sudo apt-file update?
    – mchid
    Commented Jul 28, 2015 at 10:14

10 Answers 10


Install the package unity-webapps-service

  • 3
    I have the same problem but can't install the package. I get this error message: The following packages have unmet dependencies. unity-webapps-service : Depends: webapp-container
    – Mrokii
    Commented Feb 24, 2015 at 10:12
  • 3
    sudo apt-get install unity-webapps-service IS proper command Commented Apr 4, 2015 at 5:47
  • 2
    I dont want webapps in my Desktop PC... Why can I not use a tweak tool without having a completely useless Ubuntu browser
    – inimene
    Commented May 2, 2015 at 17:52
  • 2
    @Florian: Wow! For me that pulled 120MB of qt dependencies.
    – ccpizza
    Commented Sep 28, 2015 at 17:38
  • 6
    Does this mean that the package for Unity Tweak Tool should have this package as a dependency but doesn't?
    – andrybak
    Commented Oct 12, 2015 at 21:28

Just a command line way to do jackyzy823's answer:

mkdir tweak;cd tweak
sudo apt-get download unity-webapps-service
ar xvf *
tar xvf data*
sudo mv usr/share/glib-2.0/schemas/com.canonical.unity.webapps.gschema.xml /usr/share/glib-2.0/schemas/
sudo glib-compile-schemas /usr/share/glib-2.0/schemas/
cd ..; sudo rm -Rf tweak
  • 4
    Beautiful! Works like a charm if you can't get the webapps-service to install. Thanks. Commented Oct 28, 2015 at 10:23
  • 2
    Thanks, I have upvoted both answers. Just a suggestion, though: you might want to specify which answer you mean by 'above' - in this case jackyzy823's answer. Commented Nov 8, 2015 at 2:24
  • 1
    In my case I didn't install anything. My theme and custom icon pack randomly stopped working and returned to default. Trying to re-configure it with Unity Tweak Tool failed with the same error as the OP. This answer fixed it.
    – Nahuel
    Commented May 9, 2016 at 19:10
  • 1
    In my case, I was getting this error because I actually do not have the notify-osd package installed; I am using xfce4-notifyd instead. So my fix was exactly as @mchid explained, only I downloaded notify-osd instead of unity-webapps-service. Works like a charm. Commented Feb 28, 2017 at 20:57

A tricky way for this,because i do not want to download so many dependencies for unity-webapps-service.

extract the file com.canonical.unity.webapps.gschema.xml (you can see it in http://packages.ubuntu.com/trusty/amd64/unity-webapps-service/filelist) in package unity-webapps-service,put this file to /usr/share/glib-2.0/schemas/ and finally sudo glib-compile-schemas /usr/share/glib-2.0/schemas/ and it works.

  • 2
    Thanks! This is the best answer, as unity-webapps-service refuses to be installed.
    – Sumit Jain
    Commented Jul 13, 2015 at 6:19
  • Where do I find the schema file?
    – thesdog
    Commented Sep 1, 2015 at 21:55
  • @thesdog go here packages.ubuntu.com/trusty/unity-webapps-service. Download the deb package, and unpack using the instructions in the post below by mchid. Commented Oct 28, 2015 at 10:18

Simple solution.

Just Install necessary packages.

sudo apt-get install unity-webapps-common
  • 1
    Installing this package solves the problem. At least for 14.10. Commented Feb 4, 2015 at 12:46
  • 2
    I get this error: The following packages have unmet dependencies: unity-webapps-common : Depends: unity-webapps-service (>= 2.3.8-0ubuntu3) but it is not going to be installed E: Unable to correct problems, you have held broken packages. Synaptic says I have no broken packages.
    – Marc
    Commented May 4, 2015 at 1:13
  • how did you know to install unity-webapps-common ? It's not mentioned at all in the error screen shown in OP. Is it mystic knowledge that comes to you when you sleep?
    – frumbert
    Commented May 7, 2015 at 10:23

I had no problem installing webapps service and webapps common. My exact problem was the package


was missing. I misread the screenshot in this question, and spent more than half an hour trying to figure out why even though unity webapps service and webapps common are installed unity tweak tool is not working. Finally I found out the above package was missing instead of the one mentioned in the screenshot.

To solve this error, install the unity-lens-files package

sudo apt-get install unity-lens-files

That's it. Unity Tweak Tool is now working! (finally!)


For those who still need a solution: the problem occurs if one uninstalls the overlay scrollbars. To solve the problem, install the overlay scroll bars again (sudo apt-get install overlay-scrollbar) and disable them via the Unity Tweak Tool itself. (System > Scrolling)


In case of Ubuntu 19 or later, install the unity-lens-applications package by running:

sudo apt install unity-lens-applications

Simple, and effective type

sudo apt-get install unity-webapps-common unity-webapps-service

into the terminal

  • yes..dear, that answer in already given above. Installing unity-webapps-service is enough. Commented Apr 25, 2015 at 14:56

You need is to use synaptic. Try these:

  1. Install synaptic: "sudo apt-get install synaptic" in the terminal.
  2. Open Synaptic from the dash or from terminal sudo synaptic.
  3. Click on Custom Filters then Missing Recommended Packages.
  4. Highlight all and right click mark for installation
  5. Click apply on the toolbar.

Go to the terminal and run the following commands. This works for me. Hope it works for you.

sudo apt-get install --reinstall notify-osd
sudo apt-get install --reinstall overlay-scrollbar

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .