My system has been suffering from random freezes lately. I think it might have something to do with my graphics card which I've hopefully fixed it.

However, after one of those freezes I was forced to reboot my system and since then my sound no longer works and more specifically all I hear out of my speakers are random pops every 5-10 seconds.

This was a clean install of Ubuntu 11.04 and sound was working previously just fine. The speakers still work as I've tested them on another machine.

I was not attempting to fix the graphics card problem at the time the sound stopped working, I fixed that problem later after the sound was already popping.

I've tried removing ~/.pulse & ./pulse-cookie

I've tried reinstalling pulseaudio with:

sudo apt-get --purge remove linux-sound-base alsa-base alsa-utils
sudo apt-get install linux-sound-base alsa-base alsa-utils

I've added options snd-hda-intel model=auto to my /etc/modprobe.d` file.

My sound is not muted.

The speakers pop even if my volume is muted.

alsamixer shows that all my volume levels are set to 100%

I do not have my HDMI selected instead of my regular stereo analog output (in fact, I've disabled my HDMI output entirely in System -> Preferences -> Sound)

I've made sure that my user account is added to the audio, pulse and pulse access groups.

Here are a couple of outputs that might be useful:

$ dmesg | grep -i hda

[    5.455970] HDA Intel 0000:00:14.2: PCI INT A -> GSI 16 (level, low) -> IRQ 16

[    5.545302] HDA Intel 0000:01:00.1: PCI INT B -> GSI 19 (level, low) -> IRQ 19
[    5.545305] hda_intel: Disable MSI for Nvidia chipset
[    5.545349] HDA Intel 0000:01:00.1: setting latency timer to 64
[  471.612677] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
[ 1078.442662] hda-intel: IRQ timing workaround is activated for card #2. Suggest a bigger bdl_pos_adj.

$ cat /proc/asound/cards

0 [SB             ]: HDA-Intel - HDA ATI SB
                  HDA ATI SB at 0xfbff8000 irq 16
1 [U0x46d0x825    ]: USB-Audio - USB Device 0x46d:0x825
                  USB Device 0x46d:0x825 at usb-0000:00:13.2-3, high speed
2 [NVidia         ]: HDA-Intel - HDA NVidia
                  HDA NVidia at 0xfe77c000 irq 19

$ aplay -l | grep card

card 0: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
card 0: SB [HDA ATI SB], device 1: ALC892 Digital [ALC892 Digital]
card 2: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
card 2: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
card 2: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
card 2: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]

$ sudo lsmod | grep snd

snd_hda_codec_hdmi     28103  4 
snd_hda_codec_realtek   336693  1 
snd_hda_intel          33211  2 
snd_hda_codec         103804  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_usb_audio         112426  1 
snd_usbmidi_lib        25139  1 snd_usb_audio
snd_hwdep              13604  2 snd_usb_audio,snd_hda_codec
snd_pcm                96625  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_usb_audio
snd_seq_midi           13324  0 
snd_rawmidi            30486  2 snd_usbmidi_lib,snd_seq_midi
snd_seq_midi_event     14899  1 snd_seq_midi
snd_seq                61621  2 snd_seq_midi,snd_seq_midi_event
snd_timer              29602  2 snd_pcm,snd_seq
snd_seq_device         14462  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    67382  18   snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_usb_audio,snd_hda_codec,snd_hw    dep,snd_usbmidi_lib,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              12680  1 snd
snd_page_alloc         18529  2 snd_hda_intel,snd_pcm

This is a desktop machine, not a laptop.

Any help would be much appreciated. Thanks in advance. Please let me know if there is any other information that might be helpful.

closed as off topic by Marco Ceppi Feb 5 '12 at 20:36

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here. If this question can be reworded to fit the rules in the help center, please edit the question.

  • We need more hardware information to help you, can you look at this question and then edit your question adding the information. – Jorge Castro Feb 5 '12 at 19:21

Browse other questions tagged or ask your own question.