After upgrading from 12.04 to 14.04 I could log in to my X session (albeit with really low graphics). While trying to fix the graphics, I managed to break the X session.

Now, after typing my password in the unity-greeter, the items disappear and I can only see the desktop background and the pointer. This happens for every user. I can still log in in tty's. How can I solve this?

Also, I cannot seem to be able to install nvidia-current as it tries to install nvidia-304 and it depends on old video-abi libraries. Is there a way to tell the package manager that nvidia-current should use a newer version?

  • I got the same problem with my VAIO Laptop using a radeon GPU. I already had some difficulties after the upgrade of the fglrx-package, could that be the reason?
    – user272101
    Apr 21, 2014 at 18:50
  • I got similar issue after upgrading from 13.10 to 14.04 with Nvidia GeForce graphics. Tried reinstalling ubuntu-desktop, unity, drivers and xorg. None of it worked. Any help is appreciated!
    – asgerbj
    Apr 23, 2014 at 11:10
  • 2
    Check the content of ~/.xsesssion-errors and /var/log/Xorg.0.log for clues.
    – Oli
    Apr 23, 2014 at 11:42
  • I decided to do a fresh install as I needed to work on that computer. However, while trying to fix it, I tried many things including reading the logs (there were errors there, but nothing I could figure out how to solve), reinstalling unity and Ubuntu-desktop and the NVIDIA drivers.
    – fabikw
    Apr 23, 2014 at 15:21
  • 1
    @Seth I gave up, but this question is still relevant as lots of people seem to be having a similar problem. If there's a solution that seems to be helping people, I'll gladly accept that as an answer.
    – fabikw
    Apr 25, 2014 at 16:59

9 Answers 9


This bug depends on several factors, including Video card and custom config files. For example, some users have solved the issue by doing one or several of the following "solutions" (Not all work for everyone, some users even need a combination depending on how the session was configured and hardware used):

Fix 1 - Compiz Problems (OpenGL module not loading, Unity plugin not loading)

sudo rm -fr ~/.cache/compizconfig-1
sudo rm -fr ~/.compiz

Fix 2 - Session not loading (Guest session loads fine)

sudo rm -fr ~/.Xauthority
sudo rm -fr ~/.config/autostart

Fix 3 - Session not loading (Guest not loading)

sudo apt-get install --reinstall ubuntu-desktop unity compizconfig-settings-manager upstart

Fix 4 - Launcher / Top Panel not loading (Nvidia cards)

sudo add-apt-repository ppa:xorg-edgers/ppa -y
sudo apt-get update
sudo apt-get install nvidia-340
sudo reboot

Fix 5 - Clearing Unity

dconf reset -f /org/compiz/
setsid unity

Fix 6 - Clearing the Cache

sudo rm -fr .cache/*

WARNING - This will clear the cache for all apps inside of the .cache folder.

For most of these cases, if the session opens and you still can not see the top panel or the launcher, try opening a terminal CTRL+ALT+T and typing ccsm (Assuming you already installed the compizconfig-settings-manager package) then enable the OpenGL plugin and the Unity Plugin. If the driver is working well, this should enable both panels in a couple of seconds. There are even some cases where the Unity plugin in the compiz config settings manager is simply not enabled.

  • 2
    One of the few things that worked for me. I owe you a coffee my friend. Thanks
    – VA6DAH
    Jul 29, 2014 at 0:45
  • 3
    Line 1 in Fix 5 worked for me. (Had to additionally set the DBUS_SESSION_BUS_ADDRESS as outlined in askubuntu.com/questions/457016/…) Nov 27, 2014 at 0:57
  • 3
    Fix 5 worked for me. I ran into this problem when downgrading nvidia drivers on Ubuntu 14.10
    – Confusion
    Feb 22, 2015 at 13:09
  • 1
    @LuisAlvarado Fix 5 worked for me finally after hours of searching for a fix to my fresh install of Ubuntu 16.04! Thank you so much
    – Illidanek
    Apr 21, 2016 at 19:42
  • 1
    Step 5 should not use sudo, just: dconf reset -f /org/compiz/; setsid unity Jun 15, 2016 at 5:57

This is what fixed my problem. Once you are booted up to the blank desktop... press CTRL + ALT + F1.

apt-get install --reinstall ubuntu-desktop
apt-get install unity
apt-get purge nvidia* bumblebee*
apt-get install nvidia-prime
shutdown -r now

When the computer came back, my login screen was in high-def resolution. I entered my password. WAIT for a minute, there is a startup delay and BAM desktop appeared and popups whre there, little slow on the start up.

  • 1
    I'll give you the bounty even though it didn't totally fix my issue. This was the closest answer so congratulations. But you got me on the idea of drivers being the problem, however "nvidia-prime" was not working for me, but "nouveau" did.
    – asgerbj
    Apr 25, 2014 at 20:09
  • Unlike Asger, it worked with nvidia-prime and probably spare me hours of research. I should have think that nvidia driver was the cause of the problem.
    – L. G.
    May 11, 2014 at 20:10
  • This 'workaround' really saved my day. Thanks A LOT! Now I will stick with the nouveau (xserver-xorg-video-nouveau) drivers. Damn Nvidia all the time! (Because they crashed with 64-bit Chrome after upgrading to 14.10.) I thought I lose my working day on reinstalling Ubuntu. Pheww... Sometimes, a few (simple) commands can make a BIG difference.
    – BottleNick
    Oct 29, 2014 at 10:08
  • I had this problem after a normal apt-get udate/upgrade. This answer help me to get my desktop back. After this I had to reinstall the nvidia-driver in system-settings. Jan 30, 2015 at 23:39
  • This fixed my XPS M1530 with nvidia 8600M chipset.
    – txyoji
    Feb 26, 2015 at 4:35

I was using a custom theme with my older version(12.04) so i reset it to the default. first i tried switching to the Ambience(default) theme. you may try thst through right clicking and selecting " Change Desktop Background. through there you can get into some settings menus.


you can reset Compiz. You'll need to do it though outside of Unity. Log out, switch to a console (CTRL+ALT+F1) and then delete your Compiz settings and cache:

rm -r ~/.cache/compizconfig-1
rm -r ~/.compiz

Log out of the console, switch back to the GUI (CTRL+ALT+F7) and log in. Compiz should fall back on it's defaults, and you'll have your desktop back, minus any customization you may have done.

I rebooted and everything worked... better than it did. still a few issues but not related to this one. also this is my first answer post, be gentle.

  • After having fixed nvidia drivers and updating to nvidia-337 this answer was the final step required.
    – Halsafar
    Jun 4, 2014 at 20:56

OK, I managed to fix my problem following this procedure.

I booted Ubuntu in advanced settings and first repaired all destroyed/corrupted packages. I had a total of 700 MB of corrupted packages to be fixed from a crash during the 13.10->14.04 upgrade. Afterwards i booted into the root terminal.

I then went ahead to remove all proprietary drivers by

sudo apt-get purge nvidia* bumblebee*

And then went ahead to install the opensource 'nouveau'-drivers which in general are not recommended (performance wise), but since i don't need any extensive 3D graphics on my work computer and all other drivers failed to work for me, this was the only solution.

sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core xserver-xorg-video-nouveau

After trying to fix my issues in various ways i wanted to make sure that i didn't screw up the Unity and Ubuntu packages, so i reinstalled those

sudo apt-get install --reinstall ubuntu-desktop unity

I rebooted my computer and everything has worked ever since. I'm not sure if its my computer or the drivers, but i was not quite satisfied with the speed of Unity/Compiz, so i installed the Compiz Config Settings Manager and changed visual effects from "Good" to "Fast"

sudo apt-get install compizconfig-settings-manager
  • this worked for me as well
    – cylondude
    Dec 16, 2015 at 5:34

If you gave up then you cannot confirm if this solution works for you or not. But I will post anyway in the hope that somebody else may benefit from it.

Short version:

Please, try renaming the directory /home/[user_name]/.config/dconf to /home/[user_name]/.config/dconf.original

Do it from a text terminal or if you can use gui (more of this latter) do it from a different session than the user session being fixed. Then login again as the affected user. Did the problem solve?

Long version:

My system has 4 users. Two users are members of the admin group and can use the sudo command. I upgraded from 13.10 to 14.04. After some time using 14.04 the second admin user started to have the same problem, from login at the greeter to a background image with a mouse pointer and nothing more, no menu bar at the top of the screen and no unity launcher to start programs, also CTRL+ALT+L didn't work anymore, to close the session go to another tty and use sudo restart lightdm was necessary.

The affected user can use Gnome 3 without problems, only Unity session was affected.

As all others users could login using Unity or Gnome 3, It was obvious that something got corrupted in the side of the affected user. I wanted to fix that session without having to delete the user and recreate It. So I renamed his .config directory in the hope that inside It a configuration file was causing all this. And It was exactly that. The next login attempt into a Unity session was OK (but all programs reseted to their defaults). If I put the original .config directory in place, problem reappeared. Then I started to work in the .config directory, first I renamed half of its subdirectories (there were about 40 subdirectories), and in the first attempt I'd hit the group that contains the culprit. Then I'd put in place half of that half, and problem reappeared. Then I renamed half of that last group and... I think you already know how this goes on.

Using this method I eventually hit the culprit. Rename dconf directory solved the problem.

.config/dconf contents (actually a single file) does not necessarily have to be corrupted. Maybe it is not corrupt (at the filesystem level, my filesystem is clean) but contains invalid data that ended there because of some bug in who knows which component of the system.

Also I noted in your case all users are affected, so this may not be the solution to your problem. But I think that It's possible that all users experience this at the same time and still may be caused by the same file (at each user .config directory).


I had the same problem!

I purged the fglrx

sudo apt-get purge fglrx-*

I also clear the compiz and cache

mkdir ~/backup
sudo mv ~/.compiz ~/backup
sudo mv ~/.cache ~/backup

after rebooting and logging in, wait a while. It eventually appeared.

  • I did a sudo apt-get install --reinstall fglrx and hoppa, works!
    – TTT
    Jun 23, 2014 at 19:45

Starting from June 3rd, 2014 I had this problem on several computers with Intel VGA and none of the proposed solutions has solved the problem.

After several days of researches and attempts I found to be caused by the package xserver-xorg-video-intel found in Xorg-edgers PPA.

To solve the problem, simply run these two commands:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:xorg-edgers/ppa

and then reboot.


Something like:

sudo dpkg-reconfigure xserver-xorg

should reconfigure X.

Once you can login, you should just be able to download the driver directly from nVidia's site and install it that way.

  • This didn't work. I've removed NVIDIA and did dpkg-reconfigure but I still cannot login.
    – fabikw
    Apr 18, 2014 at 21:46
  • Keep in mind that the newest X server doesn't require a configuration. Try removing your x config completely and see if it picks things up for you by default. You can also drop to a tty and do: sudo Xorg -configure You may also try re-installing nvidia-current as well.
    – lbaile200
    Apr 18, 2014 at 23:40
  • I've managed to fix nvidia. I was missing one of the repositories. However, I still can't login to Unity (nor Gnome): after the login screen, it just displays the background. Is there any way to properly debug it?
    – fabikw
    Apr 18, 2014 at 23:58
  • The top reply at this post seems pretty useful. askubuntu.com/questions/304324/…
    – lbaile200
    Apr 19, 2014 at 0:27
  • I cannot open anything from the background screen (no terminal, no context menu). Tried reinstalling unity and ubuntu-desktop as it says in the answer but that didn't solve it.
    – fabikw
    Apr 19, 2014 at 0:39

The problem is update gnome-session. After reboot run these two commands:

open command line CTRL+ALT+F1

Sign in

sudo apt-get update
sudo apt-get install gnome-session
reboot your system

The problem is solved

Not the answer you're looking for? Browse other questions tagged .