8

I installed Vidalia , and added a user to debian-tor group.

But when I run it , it gets me error:

$ vidalia 

(process:5691): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
An AppArmor policy prevents this sender from sending this message to this recipient, 0 matched rules; type="method_call", sender="(null)" (inactive) interface="org.freedesktop.DBus" member="Hello" error name="(unset)" requested_reply="0" destination="org.freedesktop.DBus" (bus)

(<unknown>:5691): GLib-GIO-ERROR **: No GSettings schemas are installed on the system
Trace/breakpoint trap (core dumped)

How can I solve it?

1 Answer 1

16

I tried it:

sudo ln -s /etc/apparmor.d/usr.bin.vidalia /etc/apparmor.d/disable/
sudo apparmor_parser -R /etc/apparmor.d/usr.bin.vidalia
sudo /etc/init.d/tor start

Ok , now vidalia works fine:

$ vidalia
3
  • works but what does it do ?
    – TiloBunt
    Commented Aug 7, 2014 at 1:14
  • @TiloBunt as far as I know vidalia needs permission or access to something that apparmor doesn't allow. have a look into wiki.apparmor.net/… it will tells you what is apparmor
    – mortymacs
    Commented Aug 8, 2014 at 5:25
  • 1
    here a site which explain the CMD: cyberciti.biz/faq/ubuntu-linux-howto-disable-apparmor-commands before running your workaround check via $ sudo apparmor_status would be a good idea and confirm afterwards that it's disabled
    – TiloBunt
    Commented Aug 8, 2014 at 6:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .