11

I just installed Ubuntu 14.04 but my screen resolution is set too low: I tried to add a new one but i keep getting

xrandr: Failed to get size of gamma for output default

I tried :

$ xrandr -q
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected primary 640x480+0+0 0mm x 0mm
   640x480        73.0* 
  1024x768_60.00 (0x194)   63.5MHz
        h: width  1024 start 1072 end 1176 total 1328 skew    0 clock   47.8KHz
        v: height  768 start  771 end  775 total  798           clock   59.9Hz

(I didn't have this problem on Ubuntu 13.10 13.04 12.04)

$ xrandr --newmode "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync
xrandr: Failed to get size of gamma for output default

$ lspci | grep VGA
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

============================================================================ I did an update yesterday on my Ubuntu 12.04 and it ruined my screen resolution due to something about 1204_HWE_EOL

I'm back to Ubuntu 14.04 and the only way to get a nice screen resolution is to start from the recovery menu then resume boot.

  • have you checked device manager to find new driver? – mortezaipo Apr 18 '14 at 15:07
  • no . should i install it or is already installed – unfamous Apr 18 '14 at 15:10
  • Have a look into: System settings -> Software & Update -> Additional Drivers – mortezaipo Apr 18 '14 at 15:12
  • i tried it but i get "no additional drivers found" – unfamous Apr 18 '14 at 15:13
  • check it: ubuntuforums.org/showthread.php?t=1970250 – mortezaipo Apr 18 '14 at 15:16
5

I was having the same issue with the resolution. I'm using VirtualBox and the resolution only had one resolution option.

  1. I went to the search bar and searched for Additional drivers
  2. Next, I clicked on using x86 virtualization solution - guest addition module source for dkms
  3. Finally, I restarted the virtual machine running Ubuntu.

As soon as it booted back up the resolution was already fixed.

  • 2
    This answer is specific to VirtualBox, but the question was not about VirtualBox... – bain Mar 26 '15 at 10:13
4

Create/edit /etc/X11/xorg.conf:

Section "Device"
  Identifier "Generic Video Card"
    VendorName  "Silicon Integrated Systems [SiS]"
        BoardName   "771/671 PCIE VGA Display Adapter"
    Busid "PCI:1:0:0"
    Driver "vesa"
    Screen 0
        Option "UseFBDev" "true"
        Option "DPMS"
        Option "ShadowFB"
        Option "MaxXFBMem"
        VideoRam 262016
        Option "RenderAccel" "true"
        Option "AllowGLXWithComposite" "true"
        Option "backingstore" "true"
        Option "AddARGBGLXVisuals" "True"

EndSection

Section "Monitor"
    Identifier    "Configured Monitor"
    Vendorname    "Generic LCD Display"
    Modelname    "LCD Panel 1280x800"
    HorizSync 20-107
        VertRefresh 50-185
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
  modeline  "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
  modeline  "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
    Gamma    1.0
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
    Device        "Configured Video Device"
    Defaultdepth    24
    SubSection "Display"
        Depth    24
        Virtual    1280    768
        Modes        "1280x768@60"    "1280x720@60"    "800x600@60"    "1280x800@60"    "800x600@56"
    EndSubSection
EndSection

Section "Module"
    Load "dri"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
    Load "GLcore"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "int10"
    Load "vbe"
    Load "speedo"
    Load "record"
EndSection

Section "DRI"
        Mode 0666
EndSection

This worked for me. (Saw on this thread on Ubuntu Forums)

  • This is a near-perfect solution for me, but not quite! I have a an Acer Aspire 5000 with "SiS M760GX" video card (lspci -v returns Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter (prog-if 00 [VGA controller])) and using this xorg.conf file I can now get resolutions of 1280x768, 1024x768, 800x600, or 640x480. However, my screen's native resolution is 1280x800, so it still looks a little off. ANY IDEA HOW I CAN GET 1280X800 TO WORK? – Gabriel Staples Sep 1 '17 at 18:07
  • I just posted this question here: askubuntu.com/questions/952001/… – Gabriel Staples Sep 1 '17 at 18:20
0

The sis 671 is not supported by Ubuntu. There's a (bad) driver for it that at least allows you to change the resolution but doesn't work since Ubuntu 12.0.2. Older versions and other derivatives of 12.04 still work with it.

This page used to contain a installation guide for Ubuntu but was changed to a Linux Mint guide some time ago.

If you're lucky it still works on Ubuntu 12.04.

A year ago I got it to work with Xubuntu 12.04 but I can't remember how.

I found an old Launchpad bug report with the same problem. Maybe the solution in this comment works for you:

  • yes it's a problem with my graphic card .. so i guess i'm stuck with Ubuntu 13.10 .. thank you – unfamous Apr 21 '14 at 13:11
  • Sorry, I just read what your current resolution actually is. Even without a proper driver 1024x768 should work. The vesa driver is capable of this resolution. Did you upgrade from 13.10 or did you do a clean install of 14.04? – user222723 Apr 21 '14 at 15:30
  • i did a clean install – unfamous Apr 21 '14 at 16:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.