36

I installed the latest ubuntu desktop and when I install xrdp I get a grey screen when I connect from windows rdc. this works fine in ubuntu 12.04.

I found several solutions but they are not really what I want. I would like for the ubuntu desktop to function with xrdp.

Any suggestions?

I have tried pretty much every post on xrdp "grey screen". I was able to get the xfe desktop to work but I really want the ubuntu desktop to work.

I did the following to install xrdp:

sudo apt-get update sudo apt-get install xrdp

Restarted the ubuntu 14.04 desktop machine.

RDC from windows results in a grey screen with an "x" cursor.

The process of doing the update and installing xrdp works fine for ubuntu 12.04 desktop and I can get into the desktops via windows RDC just fine. But 14.04 desktop gives a greay screen.

25

Your steps are correct so far. The only thing that you should be aware of is that the xrdp solution is not working with the Unity Desktop Interface nor with the Gnome Desktop.

You can still perform a remote session to your ubuntu through xrdp but you will need to install an alternate desktop environment. The one that seems to be the most used (probably because working) is the xfce desktop.

You can find a step by step process on how to use xrdp with ubuntu 14.04 at this location http://c-nergy.be/blog/?p=5305

To summarize the steps, you install xrdp you install alternate desktop you configure your profile so xrdp know that it has to use the alternate desktop Test your configuration and possibly tweak the config as required

This should help you

By the way, you could also fill a bug report for that given that the xrdp solution is working fine on fedora (yes, you can use xrdp and Gnome interface) but it's seems that something is broken in Ubuntu and/or xrdp package

  • 2
    Thank you Thank you Thank you Thank you Thank you Thank you Thank you Thank you Thank you Thank you – Nicholas DiPiazza May 22 '14 at 14:36
12

Just to be clear in ubuntu 14.04 none of the following work as of right now:

gnome-session --session=gnome-classic
gnome-session --session=gnome-fallback
gnome-session –session=ubuntu-2d

Instead the only thing that does work is:

xfce4-session

This appears to be an issue with xrdp's support of Gnome, which I don't see listed as a bug on xrdp's git.

~/.xsession
  • 1
    I also have this problem with Ubuntu 14.04 64. I changed the session to xfce4 but it does not work!!! – Dr.DB May 11 '14 at 11:41
  • Cinnamon works, but there seems to be issues with the network manager. It only works when launched w root. – Nick Oct 29 '14 at 13:09
8

For me it worked (system restart may be required):

sudo apt-get install xrdp
sudo apt-add-repository ppa:ubuntu-mate-dev/ppa
sudo apt-add-repository ppa:ubuntu-mate-dev/trusty-mate
sudo apt-get update 
sudo apt-get upgrade
sudo apt-get install ubuntu-mate-core ubuntu-mate-desktop

echo mate-session >~/.xsession
sudo service xrdp restart

source: http://c-nergy.be/blog/?p=6046

  • 2
    Would one need to echo mate-session >~/.xsession for each of the users if more than one needs RDP? – Blender Jun 19 '16 at 9:46
  • @Blender: Yes, since the .xsession file is located in the /home folder of the respective user. – Priidu Neemre Sep 18 '16 at 2:35

protected by Community May 11 '14 at 11:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.