1

I'm running Ubuntu 14.04 LTS. I've installed Faenza icons (version 1.3.1) and used the latest Ubuntu Tweak to apply the theme. However, Faenza icons are not fully applied and I can still see some icons have their old, system default appearance. How can I fix this?

Screenshot example:

enter image description here

You can see in the screenshot here the icons for Displays, Power, Time & Date, and Sound are stuck with Ubuntu's system default ones, and I don't want that.

1
  • I have tried logging in and out, restarting the system, and re-applying the icon theme but it did nothing to fix the issue.
    – Lexdexia
    Commented Apr 18, 2014 at 13:02

2 Answers 2

0

If an app/config does not have a corresponding icon in the /usr/share/icons/Faenza* directories, it defaults to the originals which you are seeing.

For example, the 'User Accounts' corresponds to config-users.svg and the 'Universal Access' corresponds to access.svg.

It is likely that the icons for those bits are simply not there/were not created by the Faenza author. You can have a look through or raise a bug yourself on the Launchpad:

https://bugs.launchpad.net/~tiheum

If you are feeling dedicated, you can create your own icons; then find out what names they correspond to in the ambience icons folder and save yours to the corresponding location in the Faenza folder.

3
  • I used Faenza icons since 12.04 and the icons for the originals I'm seeing right now are covered by the theme. Only now in 14.04 problems like this happens.
    – Lexdexia
    Commented Apr 18, 2014 at 13:17
  • 1
    That may indicate that the icon paths that the settings window is looking for has changed which isn't unusual between version. I haven't looked through the source code to say enough so don't quote me on that. :)
    – Mendhak
    Commented Apr 18, 2014 at 13:19
  • 1
    so is there any way I can make the icon path normal and the theme to work perfectly?
    – Lexdexia
    Commented Apr 18, 2014 at 13:28
0

you can change them manually.

  1. the installed faenza icons are located in /usr/share/icons/Faenza
  2. from terminal: gedit /usr/share/applications/yourappname.desktop
  3. change the Icon=yourappname to Icon=/usr/share/icons/Faenza/yourappname and save!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .