19

I just installed Ubuntu 14.04 in a VirtualBox machine, which I am planning to use for Java/Web development. After my first steps, I noticed that the CPU usage is very high even when I do simple tasks like browsing files with nautilus. In htop I can see that it is compiz utilizing the CPU heavily.

I have already tried to disable the effects and animations with compizconfig-settings-manager, but it did not change much. I would like to keep the new Unity interface if possible.

A list of steps that leads to the best result would be great.

  • 2
    here's a list of things you can do for better VirtualBox performance: askubuntu.com/questions/289677/… – Takkat Apr 18 '14 at 11:37
  • Bizarrely, if you power your host machine with an underpowered charger, the guest OS can be severely slow. I just had this problem myself, and realized this by accident after hours of work. Just plug out your charger, if using a laptop, and try again. forums.virtualbox.org/viewtopic.php?f=2&t=42462 There are lots of possible causes of slow performance, this is one of the strangest ones – Aaron McDaid Sep 16 '14 at 22:26
  • Has anybody tried a headless machine, using an Xserver on the host to connect into the Ubuntu virtual machine? Would that make it better, because the graphics work is moved on the host? Or worse, because everything is going over the network? – Aaron McDaid Jun 20 '15 at 10:49
3

If you don't need compositing/desktop effects, then Xubuntu would be the better option.

It has a nice tool in its Settings menu to turn them off, and quite frankly you won't lose anything by installing Xubuntu if you're only going to use it for web/java development. You'll be using the same apps as you would do in Ubuntu.

0

Have a look at this answer related to 12.10. For me it works great now.

The cpu load goes up, because it does a bad job at performing GPU tasks... but the CPU is forced to do so... just have a look at the linked thread.

-4

You could just run a completely headless ubuntu box and do everything via command line.

Otherwise lubuntu and xubuntu are pretty light weight, you could try openbox.

Command line is the best way, however.

  • This doesn't answer the question. – dschulz Apr 22 '14 at 23:47
  • Sure it does, He said he tried disabling desktop effects but it did not solve the problem. He then wanted to know if there was something simpler than just trying Xubuntu. I gave an answer of alternatives and things that would be simpler/more efficient. – lbaile200 Apr 22 '14 at 23:50
  • 1
    You could recommend him to use MS-DOS 6.2 as well, that's a "simpler solution". What he asked for is a simpler solution to disable animations. – dschulz Apr 23 '14 at 0:21
  • Is it wrong of me to assume that he has already tried to disable animations. Considering that he said: "I have already tried to disable the effects and animations with compizconfig-settings-manager, but it did not change much." I gave a list of alternatives and a more lightweight solution. Just because you don't like it doesn't mean that it is not an answer. – lbaile200 Apr 23 '14 at 0:22
  • Sorry, yes. First, it's totally unreasonable to do Java/Web development in a headless environment. You can't run an IDE from a command line and no sane man will try to do Java/Web development without an IDE. And then there are simpler solutions to disable animations, adjust hardware acceleration settings, etc, as you can see in the link posted by Takkat in the OP question. – dschulz Apr 23 '14 at 0:41

protected by Community May 28 '14 at 12:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.