I install fresh Ubuntu 14. 04 server under ESXI 5.1.0.
During my installation I did not get any erorrs or strange things. My problem is when I boot machine at console screen I get messages like

[ 6.958104] intel_rapl: no valid rapl domains found in package 0 
[ 7.508153] intel_rapl: no valid rapl domains found in package 0
[ 8.058695] intel_rapl: no valid rapl domains found in package 0
[ 8.609932] intel_rapl: no valid rapl domains found in package 0
[ 9.163260] intel_rapl: no valid rapl domains found in package 0

After that messages I am able to log in and my to me Ubuntu works OK. I have internet connection I am able to call apt-get update and I am able to login over SSH.

Should I investigate these errors deeply before I continue build my server.
Do I need to react on these Messages or it is ok to run Ubuntu like this.

  • 12
    The intel_rapl message was driving me crazy. The solution for me was to (sudo) edit /etc/modprobe.d/blacklist.conf and add blacklist intel_rapl. No more messages after reboot. – Zyphrax Nov 12 '14 at 6:18
  • odd... i got this on a fresh install under Parallels and the initial boot process doesn't get past seeing this message. – Michael Jun 30 '16 at 19:41
up vote 37 down vote accepted

This was a change introduced in October 2013 to support Intel RAPL power capping driver in the Linux kernel. This message is non-obstructive, and when it appears it doesn't affect the performance or functionality of the system, since it's only a power management module.

If your virtualization software supports this driver (and the host supports advanced power features) then the message disappears.

You can check the source tree of the module to check what it does.

I know in VirtualBox you can enable PAE/NX which will solve "no valid rapl domains found in package" on Ubuntu 14.04 LTS. I don't know how about ESXI if it supports PAE/NX or not.

Virtual Box Enable PAE/NX

  • 21
    I'm on 14.04, with PAE/NX enabled, and still see the message. – cHao Jan 20 '15 at 6:32
  • 5
    I tried your solution to run Ubuntu 16.04 LTS and it worked like a charm. Thanks. – H.Josef May 15 '16 at 17:54
  • 1
    I still see the message but it can boot into Ubuntu. – SmallChess May 30 '16 at 1:01
  • 3
    Same here. Still saw the message even with PAE/NX enabled. Oh well, no big deal. Just a bit annoying :-) – pepoluan Dec 3 '16 at 6:11
  • 2
    Did not work for me. – Organic Marble Apr 22 '17 at 16:57

edit the *.vmx file and set paevm = "TRUE" in order to enable PAE - or blacklist the module:

echo 'blacklist intel_rapl' >> /etc/modprobe.d/modprobe.conf
mkinitcpio -p linux
reboot
  • 1
    I don't know what mkinitcpio is, but simply adding blacklist intel_rapl to /etc/modprobe.d/blacklist.conf removed that message (note the different filename on my Linux Mint). All I wanted was this rap-whatever to not taint my splashscreen and now it doesn't. – user3125367 Aug 9 '17 at 9:41
  • @user3125367 mkinitcpio is the program you use to re-generate the init image file that accompanies the kernel at boot time. It contains all settings/drivers/whatever else the kernel needs at boot time before the actual filesystem has been mounted. – Lennart Rolland Sep 1 '17 at 7:51

protected by Seth Apr 24 '14 at 19:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.