10

In its current state, using the Ubuntu Browser app I can't copy or paste. App won't remember the default size each time I open it, and I get graphical artifacts (lines, etc.) on my screen each session.

How do I change the default application to use either Firefox or Chromium?

4

On Ubuntu 14.04

  • Open All Settings.
  • Click on Details under System.
  • On the next window, click on Default Applications.
  • Choose your desired browser.
3

Try these two (tested in 14.04):

sudo update-alternatives --config x-www-browser
sudo update-alternatives --config gnome-www-browser

These will prompt you to select a default from the installed browsers:

~> sudo update-alternatives --config x-www-browser
There are 2 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).

  Selection    Path              Priority   Status
------------------------------------------------------------
  0            /usr/bin/firefox   40        auto mode
  1            /usr/bin/firefox   40        manual mode
* 2            /usr/bin/midori    39        manual mode

Press <enter> to keep the current choice[*], or type selection number: 
1
  • This is the best answer if you prefer to do things without a GUI.
    – joctee
    Dec 16 '15 at 10:29
1

You could edit the .desktop file for the Ubuntu Browser in /usr/share/applications/. I don't use Unity so I can't tell you what's the correct file. But I assume it's ubuntu-browser.desktop

Now open this file in an editor with root permission: sudo nano filename or gksudo gedit filename (You can use any editor you want, but the gksudo is important if you use a GUI editor.)

Change the line Exec=... to Exec=chromium-browser --app=%u and save. Now when opening a Webapp, it should be opened with Chromium (got a better app support than FFX)

To make the change revertible more easily, you should only mark the Exec line as comment:

#Exec=...
Exec=chromium-browser --app=%u

NOTE: You'll only be able to start Ubuntu Browser from console now (if you want to)

3
  • 1
    Can someone please post the name of the file if he/she tries this? The only similar file I could find is called /unitywebappsqmllauncher.desktop and it doesn't seem to work.
    – Cmorales
    Apr 19 '14 at 12:31
  • 1
    Nope, haven't been able to make it work. Tried editing the webbrowser-app.desktop file as mentioned above, and the only thing that changes was opening chrome when clicking on the ubuntu browser icon. Oh well, will just live with it until it improves.
    – dinky
    Apr 26 '14 at 6:08
  • 1
    Maybe it's %U instead of %u
    – s3lph
    Apr 26 '14 at 11:31
1

If you want to make chrome your default browser then click at the right corner the 'three lines' then click o settings on the menu. Then a new tab will open there at search for default browser and click on set chrome your default browser and done. Now chrome is your default browser. The method for chromium and firefox will be identical I think.

1

I have no idea about changing the setting trhough terminal and setting files but here you can go through the GUI enter image description here

1

Type to the terminal: sudo update-alternatives --config x-www-browser

Just type the selection number of the browser you need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.