11

I can create 14.04 VM with Parallels 9 (on OSX 10.9.2) just fine. However, once I install Parallels Tool, the launch and menu bars disappear. There's still some functionality, e.g. I can create a folder and click on it to open the Ubuntu equivalent of OS X Finder (clearly I don't know the former very well). But overall I'm severely limited (e.g. most application windows never appear).

I've looked through posts mentioning similar issues on earlier version of Parallels/Ubuntu/OSX, but none of the tips mentioned has worked for me. Any help here is much appreciated.

  • I discovered exactly the same problem. It looks like a problem with Parallels Tools because if I use the same 14.04LTS ISO to install as a VM in VMWare Fusion, I don't see the same issue. I would suggest reporting it to the Parallels guys, they can be quite responsive and generally react quickly. The more of us who report this, the quicker they will get to look into it. – CatEUChris Apr 18 '14 at 4:41
  • 1
    CatEUChris -- I did contact Parallels...and all they did was send me a link back to this post! – patrickmckenna Apr 19 '14 at 22:41
8

I had the same problem. I was able to finally get it working (after several attempts of removing and re-installing the tools, etc.) by

  1. Gain console access by Ctrl-Alt-Fn-F1 and log in
  2. Fix another issue that I recommend you fix first, since you're going to be forcing a reconfiguration anyway, which deals with the screen rescaling correctly.

    See this Parallels forum thread, though for me, when I cd to /etc/X11 there was no xorg.conf at all, but there WAS one with a date appended to the filename that looked like right before I installed Parallels Tools. It looked the same as in the post, so I mv xorg.conf.[datestring] xorg.conf

  3. rm -rf ~/.config
  4. rm -rf ~/.compiz
  5. sudo reboot This will force compiz to recreate its config, which is somehow being corrupted with the Parallels Tools install.

Yay, all better! At least for me...

  • BrettBranch - you are a genius! I didn't need to follow the procedure in the link to fix screen rescaling as this was ok. The renaming of the xorg.conf.[datestring] file and removing of the config and compiz worked for me too. – CatEUChris Apr 18 '14 at 5:11
  • On step 3, you shouldn't have to delete all of ~/.config, which contains configuration data for many applications. I was able to reset the desktop UI by just removing ~/.config/dconf. (dconf stores the GNOME configuration.) – duozmo Oct 11 '14 at 0:07

protected by Community Apr 19 '14 at 0:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.