3

So I switched to the new version of Ubuntu (14.04) and, as expected, I ran into some problems. Now I usually just go around on google and look for answers but since it's on 14.04 I didn't found any good way to solve the problem.

SO

I downloaded the .bundle file, x64 (matches my version) sudo bash the whole thing, get to the installation windows. I complete the installation successfully (Like on 12.04 and 13.10) but when I launch VMware I get:

"Before you can run VMware, several modules must be compiled and loaded into the running kernel"

I have the option "cancel" (obviously not the one I want) and the option "Install" (I clicked that one)

I am prompted to enter my password

And a second installation process launches and (Boom) Pop-up window "Unable to start services See log file bla bla bla"

Went to check the log file but I can barely understand what it means. Maybe you can?

Here it is: http://pastebin.com/XQqSdVUG

So yeah, please help me, I never had this problem before.

Thanks!

  • If you type in make in terminal, what happens? – saiarcot895 Apr 17 '14 at 23:11
  • What do you mean by make? – Belval Apr 18 '14 at 1:46
  • The command make. If you enter it in Terminal and run it, do you get a command not found error or that no Makefile was found? – saiarcot895 Apr 18 '14 at 1:49
  • since it's a .bundle I don't have a makefile :/ – Belval Apr 18 '14 at 1:54
  • I know. Open a Terminal, type in "make", and press enter. Which one of the above results (command not found vs no Makefile found) do you get? The directory you are in is irrelevant. – saiarcot895 Apr 18 '14 at 1:56
13

After looking around, you need to run this script:

#!/bin/bash

cat << EOF > /tmp/filter.c.patch
--- vmnet-only/filter.c 2013-10-18 15:11:55.000000000 -0400
+++ vmnet-only/filter.c 2013-12-21 20:15:15.000000000 -0500
@@ -27,6 +27,7 @@
 #include "compat_module.h"
 #include <linux/mutex.h>
 #include <linux/netdevice.h>
+#include <linux/version.h>
 #if COMPAT_LINUX_VERSION_CHECK_LT(3, 2, 0)
 #   include <linux/module.h>
 #else
@@ -203,7 +204,11 @@
 #endif

 static unsigned int
+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 13, 0)
 VNetFilterHookFn(unsigned int hooknum,                 // IN:
+#else
+VNetFilterHookFn(const struct nf_hook_ops *ops,        // IN:
+#endif
 #ifdef VMW_NFHOOK_USES_SKB
                  struct sk_buff *skb,                  // IN:
 #else
@@ -252,7 +257,12 @@

    /* When the host transmits, hooknum is VMW_NF_INET_POST_ROUTING. */
    /* When the host receives, hooknum is VMW_NF_INET_LOCAL_IN. */
-   transmit = (hooknum == VMW_NF_INET_POST_ROUTING);
+   
+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 13, 0)
+    transmit = (hooknum == VMW_NF_INET_POST_ROUTING);
+#else
+    transmit = (ops->hooknum == VMW_NF_INET_POST_ROUTING);
+#endif

    packetHeader = compat_skb_network_header(skb);
    ip = (struct iphdr*)packetHeader;
EOF

cd /usr/lib/vmware/modules/source
# untar the vmnet modules
tar -xvf vmnet.tar
#run a the patch you should have just saved earlier
patch vmnet-only/filter.c < /tmp/filter.c.patch
# re-tar the modules
tar -uvf vmnet.tar vmnet-only
#delete the previous working directory
rm -rf vmnet-only

You run it with root privileges.

Thanks to this website: http://fazlearefin.blogspot.ca/2014/03/vmware-workstation-10-not-working-on.html

| improve this answer | |
  • that solutions worked great – Fat Mind Jan 15 '15 at 7:45
1

Has come a new version that fixes the problem in Ubuntu 14.04 LTS. The new version of Vmware Workstation is 10.0.2 ( 17 April 2014).

About Releases Notes:

Workstation now launches on Ubuntu 14.04. Resolved an issue preventing Workstation from starting on Ubuntu 14.04.

Best Regards.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.