0

I just downloaded and installed Ubuntu server 14.04 on an embedded PC (AMD G-T40E dual-core processor, 4GB RAM, 30GB Intel SSD installed in the mini PCI-E slot). This same machine runs 12.04 just fine. I chose the 'use entire disk' option, and the installation process proceeds fine until complete and I'm prompted to reboot. Upon reboot, NOTHING shows up on the display and for a couple of seconds there is HDD activity, but still nothing appears on the screen.

I have run the install twice with the same result. Any idea on how to troubleshoot?

  • what type of graphics? – Mateo Apr 17 '14 at 21:06
  • @Mateo - The specs say the following: Integrated AMD Radeon HD 6250 graphics. A link to a quick list of specs is here. Any thoughts on how to approach troubleshooting...? Appreciate the feedback! – user3210584 Apr 17 '14 at 21:11
  • Did you try booting with nomodeset parameter enabled? – hmayag Apr 17 '14 at 21:57
  • @hmayag Appreciate the feedback. New to Linux and didn't know about nomodeset. I edited the GRUB boot params and tried nomodeset (added it after 'quiet splash' but still get a black screen. I then tried the acpi_osi= option too, but still a black screen. Am I doing something wrong? Any further ideas I could try? – user3210584 Apr 18 '14 at 1:23
  • Try this. Boot-up and wait for the HDD led to stop blinking (50-60sec). Then press Ctrl+Alt+F1 If you are prompted with a login screen then do so. If you manage to login successfully it means that the system is OK and the problem has to do with your graphics card detection/driver. If you don't get a login prompt, then there is something going wrong at a previous stage of the boot process. Also, it would be nice if you edit your question to add what you tried and how it failed (eg error messages, etc) so someone can give you a more precise answer. – hmayag Apr 18 '14 at 10:16
1

Here's how I finally got this to work: I went into the GRUB boot menu, chose Advanced Options and booted in Recovery Mode. Then I could see the boot process (no black screen) and logged in, edited /etc/default/grub and added the nomodeset param, and ran sudo update-grub and rebooted. I have no idea why modifying the GRUB boot options with the nomodeset param didn't cure the black screen issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.